Jump to content

FMSA Problems (Unexpected error has occurred)


sec39
 Share

This topic is 5548 days old. Please don't post here. Open a new topic instead.

Recommended Posts

I am having problems configuring the Web Publishing Engine. When I go to the /fmi/config page and input the IP address of the engine, it asks me to restart the filemaker service. When I try to restart the service through the website, I get the "An unexpected error has occurred."

Instead of restarting the service through the website, I restarted the service through the MMC. When I log back onto the configuration page, it doesn't recongize that the Web Publishing Service is installed, the following error I get is:

The Publishing Engine is not responding. If the Publishing Engine has not yet been configured, click here to continue.

I have tried to install the Publishing Engine both locally on the Web Server and on the Filemaker Server itself. I receive the above error both ways.

I decided to take a look at the logs and I noticed this error at the bottom, when I restart IIS.

[Mon May 15 11:46:55 2006] [jk_ajp_common.c (1198)]:) Error connecting to tomcat. Tomcat is probably not started or is listenning on the wrong port. Failed errno = 61

[Mon May 15 11:46:55 2006] [jk_isapi_plugin.c (928)]: HttpExtensionProc error, service() failed

Both the web server and the filemaker server are running Windows Server 2003 with the latest updates. Both have the 7.03 update installed.

Any ideas?

Edited by Guest
Link to comment
Share on other sites

Here is a little update on my progress. I am still having the problems, below are the steps I took to try and fix the problem, attached with a picture.

1. Uninstalled Filemaker Web Publishing.

2. Searched through the registry for 'filemaker' and deleted out entries.

3. Reboot.

4. Installed Filemaker Web Publishing.

5. Reboot.

6. Logged onto localhost/fmi/config and set up administrator account.

7. Restarted IIS and Filemaker Publishing services in the mmc.

8. Error.

fmerror.jpg

Full size: http://www.lrdc.pitt.edu/compserv/fmerror.jpg

The Web Publshing services are in fact running on the machine, but for some reason, filemaker does not recognize this.

Any ideas?

Link to comment
Share on other sites

  • 2 months later...

Be sure that Windows integrated authentication is turned off in IIS. Set it to allow anonomyous logon.

Also, turn all 4 FMS services off along with IIS, and then turn them all back on. That may help clear up any issues.

Also, do the passcode and dentifier entered into the SAT Tool match those in the WPC Console?

Steven

Link to comment
Share on other sites

That authentication is turned off, anonymous login is allowed.

There are only 2 services on that machine as this is a separate machine for Webserver and WPE. The FMSA is on a different PC.

Yes, the Passcode etc ... matches ... I'm sure of that.

Livi

Link to comment
Share on other sites

Yeah i know ... it is very difficult to investigate that.

I noticed something in the "web_server_module_log.txt" in the directory ;) C:Program FilesFileMakerFileMaker ServerWeb Publishinglogs

It is full of errors like this one :(

[Tue Aug 22 10:10:38 2006] [jk_ajp_common.c (1198)]??? Error connecting to tomcat. Tomcat is probably not started or is listenning on the wrong port. Failed errno = 61

[Tue Aug 22 10:10:38 2006] [jk_isapi_plugin.c (928)]??? HttpExtensionProc error, service() failed

Is this what is causing all the problems ? Can someone else with a working WPE check to see if he has the same errors or not ...

Livi

Link to comment
Share on other sites

Yes, I finally figured it out what was causing this problem !

While setting up the WPE engine you MAY NOT have more than 1 website running on IIS. You have to stop all other virtual hosts that run on the same IP and port as the "default website". The Jakarta engine is installed in this 'default website'.

Livi

Link to comment
Share on other sites

  • 5 weeks later...
  • Newbies

Exact same error here

WPE 8.04 on Mac OSX 10.3.9

Apache 1.3

Have not found solution.

The only way to make it work:

Uninstall WPE

Reinstall (do not restart)

Apply Update

Restart.

IWP then works.... Until a reboot.

I just reproduced this 100% on a clean installed Tiger Machine. Workingfine. Rebooted. Exact same errno -61...

Patrick Sneyers

Belgium

Link to comment
Share on other sites

  • Newbies

That's kind of interesting that you are having the same problem on a Mac. I am having my problem on Server 2003/IIS 6.

Since there isn't much activity on this thread or newsgroups though, we must be the minority or everyone else figured out a fix right away.

Link to comment
Share on other sites

  • Newbies

I think I -might- have a clue here. It seems that when Tomcat starts up at systemboot, and there is some network problem (could slow DNS), this error occurs. E.G. on the test machine (IP configured by DHCP, the default) Tomcat starts before an IP is allocated - > the problem. The working machine with static IP and DNS displays the eror after startup, but then "recovers" itself after a period of some minutes (maybe 10-15).

Note, I also have multiple virtual hosts in httpd.conf, were the VH is "off". On the test machine everything is default.

Turns out I have now 2 WPE machines talking on the same FMSA machine :P

Patrick

Edited by Guest
Link to comment
Share on other sites

This topic is 5548 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.