Jump to content

Web Security -- remote administration


Vaughan

This topic is 8544 days old. Please don't post here. Open a new topic instead.

Recommended Posts

I've just started with the Web Security databases for a FMP server that's web-sharing some databases with Web Companion. FMP 4.0v3 and WC 4.0v3 on a MacOS 9.0.4 G4 computer.

I've worked out some things, and I am successfully adding new databases and users to the Seb Security databases through the FMP client, but I cannot get the thing happening through a web browser.

I've configured WC to allow remote admin with a password. When I connect in through the web browser (into the "Web Companion Security Administration" page with just the "datbase name" field and OK buttons) I cannot get any further. Authorisation fails, even before it asks for a password.

Also, I'm not sure what the "Database Password" option is for in the Web Security database. Should it be set to the FMP access privileges password (if any)?

Any help is greatly appreciated.

Link to comment
Share on other sites

Well, it's nice to be able to post a solution.

First an explanation: I changed Web Companion from "FileMaker Pro Access Privileges" to "Web Security Database" then opened the web security files and moved the html files into the web folder. The problem was that authentication always failed if "require password" was selected for Remote Administration. It worked when no password was specified, but who'd want to run a server like that... but when a password was specified I couldn't find a userID and password combo that authenticated.

The answer was deceptively simple but not documented anywhere: the username is "admin" for remote adminsitration.

username: admin

password: what's in the Web Companion config

The lack of documentation for FileMaker Pro Web Companion is a farking crime: it makes something easy to use very difficult, due only to lack of information. Sad, very sad.

I popped into the local book store and took a read of the FMP books. Only one mentioned remote access at all, and it was obvious that the wrtiter had never actually used it, just regurgitated the FMP user manual. Hopeless.

Link to comment
Share on other sites

This topic is 8544 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.