Jump to content

"Allow exporting" required to run importing script


RussellB
 Share

This topic is 5649 days old. Please don't post here. Open a new topic instead.

Recommended Posts

Quick question...

It seems to me that if you want users to be able to run scripts that involve the "Import Records" step, they need to be members of Privilege Sets that "Allow Exporting" (under Other Privileges).

Can someone clarify this for me?

Link to comment
Share on other sites

It seems to me that if you want users to be able to run scripts that involve the "Import Records" step, they need to be members of Privilege Sets that "Allow Exporting" (under Other Privileges).

This is not correct. The Privilege Set does have to allow creation of records though. Or, alternatively, the script must be run with full access privileges.

HTH

Steven

Link to comment
Share on other sites

This isn't correct either. The UI is disabled for Save as PDF when export is turned off; however, you can script that action as well. And if run with full access privileges, it works just fine.

Now, if you want to see an anomaly, turn off export privileges, and then go and see if you can export field contents of a given field.

More information:

http://www.filemakersecurity.com

Steven

Link to comment
Share on other sites

Turning on the "Allow Exporting" allowed the members of that privilege set to run the import script. Running the script with full access privileges also worked. The thing that confuses me is that the privilege set already allows access to all fields, records, layouts & scripts invloved in the import script (so why is it necessary to run the script with full access privileges?).

Thanks for the insight!

Link to comment
Share on other sites

At a distance, it is difficult--if not impossible--to diagnose what is up with your files. However, the export privilege bit has nothing to do with allowing import into the files. The create records privilege bit does however.

What is it that you are seeing that is different here?

Steven

Link to comment
Share on other sites

This topic is 5649 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.