Jump to content

Importing Money Field from Postgres Yields ? Question Mark [solution included]


Adam S
 Share

This topic is 4410 days old. Please don't post here. Open a new topic instead.

Recommended Posts

Hi, everyone.

I was just about to post the question below and happened upon a solution just before clicking go. Though perhaps not traditional, I thought I'd post the question and resolution in case it's helpful to someone else searching in future.

The quick summary is that an importing problem in FM 11 was solved by updating my ODBC driver.

Here are the details:

Just switching an old file from 8.5 to 11 today and hitting a small roadblock.

The file includes a script with an import step pulling data from Postgres (not using ESS as it's not yet implemented for Postgres). Some of the fields being imported are "money" (AKA currency) field types on Postgres, importing into number fields in Filemaker. In v. 8.5 the import works successfully.

In v. 11, however, "money" fields that include a $ dollar sign are importing with a ? question mark value. While we prefer to keep these as number fields on Filemaker we tried changing the field type to text and got the same result. We also tried setting the field definition to auto-enter a calculated value of getasnumber(item_price) and even Substitute( item_price ; "$" ; "") (and for those tests we did uncheck the "Do not replace existing value" box).

Any ideas or existing threads that might address this please? Feeling like I'm missing something obvious here.

Thanks for your help.

SOLUTION:

Just as I was about to post I realized I should include the ODBC driver type and version I was using (which was ActualTech ODBC Driver for Open Source Databases v. 2.9x). Thinking that might be a bit out of date I updated it to version 3.0.14 and the data seems to import correctly now. It seems the driver's translation may have been updated as Postgres data types were updated.

Hope this is helpful to someone.

Link to comment
Share on other sites

This topic is 4410 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.