Jump to content

SC displays differently in List vs Form view webviewers?


baumm
 Share

This topic is 4334 days old. Please don't post here. Open a new topic instead.

Recommended Posts

I'm using FMA11.0v3 and have SC 2-744.

If I put a WebViewer connected to SuperContainer in the header of a List View layout, it doesn't display the file thumbnail or the "Upload" button.

I have "style=showdelete" included in the URL, and the Delete button doesn't show either.

However, if I change the layout to Form View, all of these are displayed.

I thought this was working in FMA10, but I just tried the same thing there and found similar problems.

So maybe it was working back in FMA9, or else I just assumed it was good in List view as well as Form view and never noticed the issue before.

I don't see a fix for this listed in the update log, but I'm going to try downloading the current version of SC to see if that helps - looks like I'm a few versions behind at this point.

Link to comment
Share on other sites

SuperContainer will work fine in the header of a list view. I suspect that there may be an error in your URL calculation that you are using. You may want to put a text version of your calculation in your header as well so that you can see what your URL is being resolved to be.

Link to comment
Share on other sites

That explanation doesn't make sense to me, since I can upload and then view files using SC in this web viewer in both List View and Form View, and because it's the SAME layout that is being toggled between List view and Form view.

Again, this is the Header portion of the layout - perhaps that has some bearing on the issue?

I just tried moving the web viewer to the Body portion of the layout (while in List mode. making no changes to the web viewer in question) and guess what? Then it shows the thumbnail, the Upload button, and the Delete button.

Please try to recreate this bug - I'd appreciate it.

Thanks!

Mark

Link to comment
Share on other sites

Just to be clear: I can upload and then view files in either List view or Form view, but when the web viewer is located on the Header portion of a List layout, it doesn't display anything (the Upload button, the file thumbnail, or the Delete button). So it's functional, just not as user-friendly as I'd like it to be.

Link to comment
Share on other sites

ONe more interesting thing to report - if I click high up in the (empty looking) web viewer box, the file opens. If I click lower down (again in blank space within the web viewer), I'm asked if I want to delete. So even the delete button is "there", just not visible.

Here is a screen grab of what I'm seeing (top is header, then you see two list rows). The web viewer in the list rows was duplicated from the one in the header.

example%20of%20list%20view%20header.jpg

Link to comment
Share on other sites

I've seen the issue you are reporting here. There seems to be some display issues with the buttons when SuperContainer is in the header for some reason. Previews, text, and icons appear properly, but the buttons will show up as text only or invisible at times.

I'll look into this a bit more and let you know when we have a fix, if it is something we can adjust and not an issue with the web viewer in filemaker and general.

Link to comment
Share on other sites

This topic is 4334 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.