Jump to content

Background Colour, View size and Rotating Images


This topic is 4322 days old. Please don't post here. Open a new topic instead.

Recommended Posts

I have three questions - thanks for any help you can give me :)

1. When in Supercontainer (applet enabled) - how do you change the background colour? I need to set it to black and it works with noapplet, but I can't figure out how to do it applet enabled.

2. I'm having trouble with Supercontainer and the webviewer - I'm trying to expand the size of a PDF to fill the webviewer, which I have set to approximately 965 pixels wide x 1250 pixels high, no matter what I do the PDF only fills about 1/2 the size. I've tried it in applet mode and noapplet mode.

3. Is there a feature in Supercontainer to rotate an image 90degrees? (i.e. multiple clicks will bring you right back to where you started)

Thanks,

Jen

Link to comment
Share on other sites

1. You cannot change the background color in applet mode. Currently this ony works in noapplet.

2. If you do not specify a width and a height the image will automatically be scaled to the size of your web viewer. If your original is smaller than the size of your web viewer then it will not be scaled up to the size of the web viewer.

Also, if you have the layout zoomed in you will not see the proper sizing in the SuperContainer web viewer, as filemaker will still report the size of the web viewer to be the layout size, not the number of pixels you are seeing. If you have the layout zoomed in you may want to instead zoom it out and increase the scale of your layout so that you don't need to zoom in.

3. This is not a feature of SuperContainer, but there is a ScriptMaster module which will allow you to rotate images. http://360works.com/scriptmaster/

Link to comment
Share on other sites

I checked out Scriptmaster and it notes that rotate is a feature for containers, since SuperContainer is a webviewer will this work?

As for #2 so if I specify a width and height will that enlarge a file larger than its original size? I've set the height and width to be the height and width of the web viewer in both applet mode and noapplet mode and its not increasing the size beyond a certain point.

If the problem is that my pdfs are a small size, is there any reason they have been imported in to SuperContainer at a small size? I've tried a number of pdfs from different sources.

1. You cannot change the background color in applet mode. Currently this ony works in noapplet.

2. If you do not specify a width and a height the image will automatically be scaled to the size of your web viewer. If your original is smaller than the size of your web viewer then it will not be scaled up to the size of the web viewer.

Also, if you have the layout zoomed in you will not see the proper sizing in the SuperContainer web viewer, as filemaker will still report the size of the web viewer to be the layout size, not the number of pixels you are seeing. If you have the layout zoomed in you may want to instead zoom it out and increase the scale of your layout so that you don't need to zoom in.

3. This is not a feature of SuperContainer, but there is a ScriptMaster module which will allow you to rotate images. http://360works.com/scriptmaster/

Link to comment
Share on other sites

Yes, scripmaster will work in conjunction with supercontainer. You will use scgetcontainer to download the file to a container, scriptmaster to rotate the image, and then scsetcontainer to re-upload the rotated file to supercontainer.

No, supercontainer will never enlarge the image larger than the original size. I recommend removing the size parameters unless you need the image to be smaller than the size of your web viewer.

If you have a 50x50 image and your web viewer is 200x200 the image will only show up as 50x50 in the web viewer.

SuperContianer does not modify the file you upload to it at all. If your original is small then it will remain small when it is uploaded to SuperContainer. If your original is large then it will remain large (though the preview image will be displayed at the size of your web viewer).

Do you have your layout zoomed in? If so, check out what I wrote in the first post about that.

Link to comment
Share on other sites

Ok great - now I understand about rotation - thanks.

I think I'm understanding my problem with sizing - I always knew that you could zoom a layout (which doesn't look the best), but your answer makes it sound like you can also change the scale. Right now the ruler that shows 10-1/2" for the height of a page is only about 5" on my screen.

I've looked around but I can't find an answer, can the scale of that ruler be changed in FM, and if it can - can it be done for just one layout?

Link to comment
Share on other sites

In the bottom left of your window there is a zoom option (also under "View" in the menu bar), which should be "100" but it sounds like you may have it set for "150" or "200." Can you check and see if that is the case?

Link to comment
Share on other sites

Thanks for getting back to me. I am aware of the zoom function but am not using it. (zoom is set to 100%) It just sounded like there may be a way to change the scale setting (ie the rulers) of a layout. Zoom is jagged when you zoom in, I thought there might be a better option.

You had mentioned that "If you have the layout zoomed in you may want to instead zoom it out and increase the scale of your layout so that you don't need to zoom in.", how do I increase the scale of a layout? I've been looking everywhere trying to figure this out.

Link to comment
Share on other sites

I was talking about adjusting font sizes up, such as from 9 or 11 to 14 or 18 to make it easier for users to see if they were needing to zoom in to 150% or 200% to work on your layout.

Also, filemaker's layout zoom does not make your layouts jagged or pixelated, as it uses vectors and fonts which can be scaled up without pixelation. If you are getting pixelation when you zoom in it sounds like you may be using your OS's zoom functionality rather than the filemaker layout zooming ([windows key] + [plus] on windows and [control] + [scroll wheel] on mac).

Your filemaker zoom in the lower left should be set to 100% to see your layouts and web viewer/supercontainer content correctly.

If you would like to give me a call we can do screensharing and take a look at the issue you are experiencing.

Link to comment
Share on other sites

ok - thanks, now I understand. The only time I get pixelation is when I go to a "zoomed" layout which I've set to 150%. And the only pixelation is the contents of the webviewer. The reason I'm having to do this is that pdfs viewed at their maximum size on the main layout are still too small to be able to easily read all the content, so I'm getting around that by going to the zoomed layout above. I'm assuming that the pixelation would be normal in this case?

I was talking about adjusting font sizes up, such as from 9 or 11 to 14 or 18 to make it easier for users to see if they were needing to zoom in to 150% or 200% to work on your layout.

Also, filemaker's layout zoom does not make your layouts jagged or pixelated, as it uses vectors and fonts which can be scaled up without pixelation. If you are getting pixelation when you zoom in it sounds like you may be using your OS's zoom functionality rather than the filemaker layout zooming ([windows key] + [plus] on windows and [control] + [scroll wheel] on mac).

Your filemaker zoom in the lower left should be set to 100% to see your layouts and web viewer/supercontainer content correctly.

If you would like to give me a call we can do screensharing and take a look at the issue you are experiencing.

Link to comment
Share on other sites

This topic is 4322 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.