Jump to content
JackLKochJr

Zulu no longer sync'ing with only one of several published calendars to iCal but DOES sync with Google Calendar

Recommended Posts

I have been using Zulu for years and have not made recent changes to my set up.  In the last week, however, one calendar (my Telephone Contacts calendar) is no longer sync'ing to iCal but does show up in Google Calendar.  iCal gives a 500 error (CalDAVAccountRefreshQueueableOperation) but, apparently, only for this calendar (as the rest of the ~7 calendars are sync'ing fine - with both iCal and Google Calendar).

Several months ago, I was getting this same iCal error after having updated to Mojave but corrected this by installing a SSL certificate. However, when this occurred, none of the calendars sync'd and they have all been working fine since I installed the SSL certificate.

I am using version 1 of Zulu, have it installed on FileMaker Server 16 on an iMac running High Sierra.

I tried to re-publish the calendars from the server but this did not fix the problem.  Any ideas why only one calendar would not sync?

Share this post


Link to post
Share on other sites

Hello,

The first thing to try is to republish your calendars, then delete and add the CalDAV account on your MAC. Instead of adding the account through iCal, add it through System Preferences->Internet Accounts. 

There may be a conflict with any Internet Accounts you already have set up, based on this thread I found about removing and re-adding a yahoo account to resolve that error.(http://capitalmacservice.com/are-you-seeing-the-caldavaccountrefreshqueueableoperation-server-error-in-ical/)

If the issue persists, please send us a log file. If you have access to your Zulu server, it will be called "Zulu.[date].log", where date is the day you produced the error in format YYYY-MM-DD, and it should be located in the following directory:

Mac: /Library/360Works/Applications/Logs

Win: \Program Files\360Works\Applications\Logs

Also, if you reproduce the error, right after you could go to the Zulu launch page([server address]/zulu), click Email Log File, fill out the form and submit it.

Likely we will ask you to upgrade to Zulu 3, because if we find that it is a bug, we will only support fixes for the current major release. It may be worthwhile to go ahead and download the current version of Zulu from our store, and install it to see if it resolves your issue. The new version of Zulu writes/reads its sync data in a different directory, so you will need to add your configurations again after installation.

Let me know if you have any questions. If you send us a log file, we'll respond through the ticket generated by the log submission.

Share this post


Link to post
Share on other sites

Hello,

I apologize for the delay in replying. I took a look at the logs and the only error I see is an Illegal Surrogate Pair error for an event with summary that starts "Wingard\, Kimberly 'Kim'\n   Telephone Contact\n[...]". Could you try excluding this event from the calendar, or maybe even deleting it, then try syncing. If that calendar still fails to sync, let's set up a screen share. I am available 11a-6p Eastern, Monday through Friday.

Share this post


Link to post
Share on other sites

No problem with the delay.  I truly appreciate your effort to help figure this out.  I did delete 3 Telephone Contact appointments with the name you indicated.  While I can't tell a difference thus far, I do need to make you aware of a slight change that I have noticed since I tried the recommendations you made.  I deleted the account on my computers and added them back using System Preferences->Internet Accounts.  Apparently, my iPhone is not synch'ing with my iCloud account as I have had to delete it and add it back separately.  

Interestingly, iCal on my iMacs is now working perfectly and Google Calendar continues to work perfectly.  The only place the Telephone Contacts are not showing up is on my iPhone.  The only difference I have noticed in the setup is that the iPhone account automatically makes the port number 443 (which is, I believe, correct) whereas the port is empty on my iMacs.  But, I would think that if that was the problem, it wouldn't be synch'ing at all.

Share this post


Link to post
Share on other sites

Is your iPhone updated to iOS 12? Like Mojave, iOS 12 requires CalDAV accounts to connect over SSL, and port 443 is the default SSL(https://) port. If the port is left empty, then the connection is made over port 80, which is the default port for http:// connections.

Share this post


Link to post
Share on other sites

It is iOS 12 (12.2).  The phone (correctly) connects to port 443 and turns on SSL.  (It is my iMacs that leave the port field empty (but still turn on SSL) despite my entering it when I created the CalDav account).  But, it is only the iPhone that is not synch'ing the Telephone Account calendar (but does synch the other 10 calendars).  The iMacs are now (for whatever reason) synch'ing all the calendars.

Share this post


Link to post
Share on other sites

Could you please submit a log file to us? Please try to set up the CalDAV account with your iPhone, then go to the zulu launch page ([server address]/zulu), log into Sync Admin with your Zulu creds, click Email Log File on the main page, fill out the form, and submit. You should receive an e-mail at the address you specify letting you know we received the submission, and we can continue to communicate through that e-mail thread.

That's odd for a CalDAV account to sync only a subset of the calendars. Are you using the same credentials to connect your calendars to your iMacs as you are your iPhone? If not, verify that the account privileges allow your iPhone to see that Telephone Account calendar. Also, are you employing a calendar subscription?

Share this post


Link to post
Share on other sites

I am sending the log file right now.  

I am using the same credential to connect my calendars to my iMacs and my iPhone.  None of the privileges that I have set up are specific for iPhone vs. my iMac or MacBook Pro.  This was working fine until a couple of weeks ago and I don't remember having changed anything.  

Thank you again for your ongoing assistance in trying to figure this out.  

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.