Jump to content
FMRadio

Importing All Records

Recommended Posts

Basic Question:

I am attempting to import 60 records from a CSV file. There are 4 fields per record: First Name, Last Name, Email and Source. 

When I choose Import Records... > File... from the File menu, everything looks good, 4 data points point to the correct field names: arrow icon "Import this field" but the rest are the double dots icon, "Don't import this field," and when I click on the Import button only the first record is imported.

I don't use Filemaker frequently enough to remember everything but when I need it, I really need it. I do not remember having to go thru and changing every icon in the Import dialog to import this field, I thought that was automatic.

I there something missing in the CSV file? I can reprocess that if required. Having to indicate to import for every record will be tedious.

Thanks in advance for any help.

 

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, FMRadio said:

4 data points point to the correct field names: arrow icon "Import this field" but the rest are the double dots icon,

If the source file has 4 columns, then this is as expected. 

 

2 hours ago, FMRadio said:

when I click on the Import button only the first record is imported.

Can you post an example of the source CSV file?

 

Edited by comment

Share this post


Link to post
Share on other sites

Thanks for your reply. The data is private names and addresses so I made an exact facsimile...

Tom,Barker,foghorn@gmail.com,Out List,Craig,Hopso,hoover@live.com,Out List,Judy,Flowerstalk,jam61@comcast.net,Out List,Lara,Oblong,uptop72@gmail.com,Out List,Judi,Thomas,mor64@gmail.com,Out List,Bruce,Fortrans,fourten@comcast.net,Out List,Dennis,Willybobba,oblong@comcast.net,Out List,Peter,Kates,fullset23@msn.com,Out List,Edward,Davies,glvb99@gmail.com,Out List,Larry,Kahn,leftbank@gmail.com,Out List,Alice,Comfortis,design92@gmail.com,Out List,

The text block is 11 records, Each record: First Name, Last Name, Email, Source

It seems to me that there should be an indicator for each record? But what would that be?

Thanks

Share this post


Link to post
Share on other sites
Posted (edited)

In a CSV file, records are supposed to be separated by a line-ending character (CR, LF or CRLF). What you posted here seems to be a single unbroken line - so if that's really what your data looks like , Filemaker will see it as a single record with 44 fields.

 

 

 

Edited by comment

Share this post


Link to post
Share on other sites

Hey thanks!

I suspected this was the problem from the start but my original attempt to address it by doing a search and replace within Apple's textedit with their marriage return was not viewed by Filemaker as a kosher new record indicator but when you said, ..."line-ending character (CR, LF or CRLF )," I realized that should try another.

This time I inserted a Line Break and the CSV imported perfectly.

Much thanks.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By ZoinksScoob
      I just upgraded my Mac OS to Mojave (10.14.4).  I am running FMP Advanced 11.0v4, and my databases are in FP7 format (due to a legacy system at work.)  I now have a repeatable "glitch" where if I perform a find in a database and there are no records that come up as results (i.e., no records match the find), regardless which choice I make next (Cancel or Modify Find), the app quits and I keep getting the window to send the issue to Apple. I can immediately re-open the database, though usually the last 2-3 changes I made weren't saved.  Other than the obvious option of upgrading the app, does anyone know of a workaround for this? Thanks in advanc.
    • By JH Howland
      Filemaker Pro 11 is running on two Windows 10 computers connected as Host and Client over a network.
      The script to import data from an Excel .csv file utilizes the following script step options:
          1. Un-Checked - Specify data source - File
          2. Check - Specify import order, Import Action
              a. Select - Update existing records in found set
              b. Check - Don't import first record (contains field names)
          3. Check - Perform without dialog
      When the Import script is run from the Host computer, and the desired .csv file is manually selected, the Excel first row field names are not imported and the second row with the data is imported as expected. (See Host Import Mapping)
      When the same script is run from the Client computer, the Excel first row field names are imported and not the second row data.  To get the proper result, I have to leave the check box for "Perform without dialog" unchecked and then manually, from the "Import Action" group, check the box for "Don't import first record (contains field names)" to get the proper data imported. (See Client Import Mapping, check box is no longer checked)
      Is this caused by a defect in FMP 11?  I can't figure out why this is happening.


    • By JH Howland
      After my Windows 10 based Filemaker Pro 11 MarinaPro Solution is launched (Path = C:/MarinaPro/Marina.fp7), I need to create a variable ($$source = filewin:/C:/MarinaPro/ResScheduler/) to a revised default "Open File" path.  Because I need to select from several reservation request attachment Excel .csv files, placed in the ResScheduler directory by an Outlook 2010 Macro, my "Import Records" script is set with an "unspecified" data source.
      When my script is activated with Error Capture "Off", I get the obligatory Filemaker Pro Error message, "The file <unknown> could not be found..." and the "Open File window is still set to "Look in: "MarinaPro" (Default).  And, of course with Error Capture "On" there is no Open File window presented.
      I have to manually select and import the first Excel.csv file before the default directory becomes "ResScheduler".
      I want my default "Open File" "Look in:" directory changed from "MarinaPro" to "ResScheduler" before I open the first Excel.csv file.
      Is there a way, nothing I have tried is working.
      Import.pdf
    • By transpower
      I've updated my computer from Windows 7 Pro to Windows 10 Pro.  My FileMaker Pro Advanced 11 does not launch.  I get the message "The application has failed to start because its side-by-side configuration is incorrect."  What's the solution for this issue?
      Update:  I clicked on an fp7 file, and then Windows asked me to insert the FileMaker CD, which I did.  Some files were quickly copied over, and everything works fine now!
       
    • By JH Howland
      I have several customers that utilize our MarinaPro Marina Dockage Management solution.  All are running Windows 10 Pro 64Bit and Filemaker Pro 11.0v2.
      All the MarinaPro solutions are functioning well with exception to the one marina that is using an HP LaserJet Professional M1217nfw MFP printer.  The printer has been named "HP LaserJet".
      The problem is that scripted reports will not print after an updated/revised solution is installed on the computer.  However, a test page can be printed from the Windows default printer.
      Print scripts are utilized by more than one report and this sample is named -  "Master Portrait Printer | Current Record | All | 1 |" and is formatted as:
      #Used by: Print Float Plan Form
      #Used by: Toggle Printer Mode
      #Portrait Orientation
      #Print: Current Record | Print Range All | Copies: 1
      Print [Restore: HP LaserJet; No dialog]
      Filemaker Help states, "If you do not specify an output destination before saving the script or 'if the specified printer cannot be found' when the script executes, the 'output from the script step is sent to the user’s default' printer."
      It appears that the "specified" printer is not being found and the output from the script is "not" being sent to the user's default printer.
      However, if I "re-specify print options" and "Save" the script it will start working again.  And now I am unclear whether it is actually finding the FMP "specified" printer or the Windows "default" printer.
      Any ideas why this occurs?
       
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.