Jump to content

Incorrect AWS version?


Recommended Posts

I'm getting this error when I attempt to list files in an S3 bucket in the eu-west-2 region.  

com.prosc.aws.exception.AWSRuntimeException: <?xml version="1.0" encoding="UTF-16"?><Error><Code>InvalidRequest</Code><Message>The authorization mechanism you have provided is not supported. Please use AWS4-HMAC-SHA256.</Message><RequestId>B67BF8D52F9A5E79</RequestId><HostId>TdW+BZFS3xxBM9pnQGLC4c8ha7jfpXwg2OJQKCovCEs5GNUM5wN3fd+lhBr8PvGbm9K/V9SwMHU=</HostId></Error>

A quick search led me to this, which directed me here.

 

Is there a way to specify the version so it uses AWS4?

 

Thanks in advance

Link to post
Share on other sites

Hello,

Thank you for bringing this to our attention. I have reported it to our developers and have created an issue in our issue tracking system. We will be bump this post when it has been addressed.

Link to post
Share on other sites
  • 3 weeks later...

Hello,

I don't have any updates at this time. I talked to the developer about this today and he is still looking into the issue. I have created a ticket in our support system as a reminder to follow up with the developer and will bump this thread as soon as I have more information. As a workaround for the time being, put the files you need to interact with in a bucket in a region that supports Signature Version 2.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.