Jump to content

FM Go script issue—Find query works on one iPad but not another


Recommended Posts

I have two iPads connected to FM server. For some reason one ipad (5th Gen running 13.5) will not complete the navigation scripts and shows error messages (no records match this find criteria), however the 7th Gen running on 13.1.1 works fine..... Issue has only begun after purchasing the second, newer iPad. I cannot for the life of me work out what is wrong, or how to troubleshoot and would love some guidance please!! Here is a screengrab of one of the scripts and related layout:

fm go script issue.tiff Orders iPad layout.tiff

Link to post
Share on other sites

Tip: don't use the "restore" option of Perform Find; we can't tell what you are searching for and neither can you by just looking at the script.  Use explicit coding and do:

Enter Find Mode

Set field ....

Perform Find

 

Show us what it is searching on.

Also show us the layout in layout mode.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Similar Content

    • By mvoogt
      Can anyone point me to resources or methods for annotating PDFs in FileMaker go on the iPad?
      Go Draw does not support PDFs. I’d like to draw on a pdf and then save it in a container. I assume I have to do this outside fm go and then bring it back into the container. 
       
      What technique requires the fewest steps?
    • By John Link
      I have a field named "Databases" with the following values: "CORD", "SDHS", "Y Ballet". This field is displayed as a checkbox set. I recently learned that "CORD" should have been "DSA", so I naively changed "CORD" to "DSA" in the value list but then none of the records that were checked for "CORD" were checked for "DSA", which reminded me that the values in the value list are the values of the field Databases and not labels for checkboxes. I revised the value list to again include "CORD" and its checkbox is again checked for all the records for which it was originally checked.

      I wrote a script, shown in one of the attachments, to insert "DSA" into the Databases field for each of the records that contains "CORD" in that field. When I run the script I get an error message saying "Databases" is defined to contain only specific values, and that I must enter a valid value. How can DSA not be a valid value when it is included in the value list for the field? How can I accomplish what I want to do?

      Does programming scripts in FileMaker ever get easier? I don't write many scripts, but when I do I find it surprisingly difficult to accomplish what I think would be the simplest of tasks.

      Thanks in advance for your help,
      John Link


    • By whardy
      [Cross Post - I posted this as Claris Community, but didn't get any bites after 24 hours]
      I am trying to scroll to the active record in List view.
      It works perfectly in Pro (19).
      I am running the script from Go (iPhone) using the FileMaker Network (lightning cable to my Mac)
      I cannot get it to work in Go. It goes to the right record and field because I can manually scroll to it, but the script won't do it.
      Here is the simple script:
      ======================================
      Go to Field [Select/Perform; Person::FirstName]
      Scroll Window [To Selection]
      ======================================
      It doesn't budge in Go.
      I have used a dialog window/Data Viewer to confirm I'm actually in the right field and on the right record, but Go will not scroll to it.
      I have tried every imaginable combination of Pause/Refresh Window/Scroll Home/Scroll End, etc.
      Nothing in the docs indicate it should work differently between Pro/Go.
      Anyone have any ideas?
    • By Greg58
      I have a shopping list app for personal use.  On the MacBook it works fine.  I have a global search field which searches through the list of existing items.  I have a script trigger (On Object Modify) on the field which allows a 'type ahead' search when each letter is entered.  On the phone in FileMaker Go, the keyboard drops off the screen and then reappears when I type each letter.  Pretty disconcerting to use.  Is there anyway to stop this please??  I have attached the script I use for the type ahead.  Thanks.

    • By Answers
      We have a Filemaker Go on iPads and there is a layout with portal rows, when scrolling through it hesitates and you must wait to scroll down. We have offline files on the iPad, although it happens when we connect to the Filemaker server as well.
      Any suggestions?
      Thank you,
      Caroline

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.