Jump to content

Can't get BE_FTP_Delete to work


Recommended Posts

Hello! Having problems getting BE_FTP_Delete to work.
 
  • BE_GetLastError reports error 21
  • SFTP server used is a Mac with macOS Mojave; doesn't work with a different SFTP Server (Another Mac with Big Sur)
  • BE_FTP_Upload and BE_HTTP_GET are working fine when connecting to the same server; I can create folders and upload files
  • I'm able to connect to the SFTP server through Terminal and delete files using the rm command
  • The plugin version is 4.1.4, and is installed in FileMaker Server 19.0.1
  • The command is running through a PSOS script, and I've tried using a local script using FileMaker 19.1.3 as well and still doesn't work
  • Using the debug info, i see the message: "rm command failed: No such file or directory"
 
Here's a sample of the URL i'm calling: sftp://192.168.1.200/~/Documents/DMT/TITAN/LFT-Logo-v2-transparent-320.png
Doesn't work also when using sftp://192.168.1.200/Users/dmt/Documents/DMT/TITAN/LFT-Logo-v2-transparent-320.png
 
Any ideas on what to do? Thanks in advance!
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.