Jump to content

ERROR -- FileMaker could not establish a connection to the MirrorSync server


Recommended Posts

Dear All, 

I don't know if a similar topic has already been opened and discussed by I'm facing a kind of major issue and can't solve it. 

I set up MirrorSync in December 2020 and until last friday, everything was running very smoothly. During the weekend, our VPN connection crashed and we finally managed to make it live yesterday. But, when we release sync, we received below message :


"FileMaker could not establish a connction to the MirrorSync server. Try the sync again, or move to an area with better wireless coverage. The failing address is http://10.0.0.20/MirrorSync/v6/sync"

We haven't changed anything on filemaker server. 10.0.0.20 is HUB. 

We checked WIFI which is OK (180 Mb/sec), we tested with LAN cable and we got same message and we tested timeout which is OK as well. 

We also, uninstall MirrorSync and reinstall it and create again the link for synchronisation which works well. We even trigger the URL address http://10.0.0.20/MirrorSync/v6/sync to see what happens and answer is "MirrorSync is up and running. However, only the MirrorSync script should call this URL."

Now, I have no clue about what really means this error message and how to solve it.

so my question is : could someone give me ideas to solve this issue ?

thanks for your kind help

Yannick

Link to post
Share on other sites

Try pasting that URL into your web browser, from the same computer or device that was having the problem, using the same network connection as that device. If you get a message like "MirrorSync is working, but only the MirrorSync script should call this URL," then that means the network connection is OK - try the sync again immediately after that and see if it works. If you get some sort of error message instead, then there is a network issue that needs to be fixed before MirrorSync can work.

Link to post
Share on other sites

Please be more detailed, Ian. Did you try the steps? Tell me what message you're getting, and whether you're getting it in the browser or when you try to sync.

Link to post
Share on other sites

Well, message I receive is still : MirrorSync is up and running. However, only the MirrorSync script should call this URL.

and from MirrorSync Client is in return : "FileMaker could not establish a connction to the MirrorSync server. Try the sync again, or move to an area with better wireless coverage. The failing address is http://10.0.0.20/MirrorSync/v6/sync"

Again, I've completely uninstalled everything and re-installed MirrorSync and this worked fine. Configuring the sync between the two servers worked properly. DATA API is on and both FileMaker Server and Database are working normally.

Unfortunately, I don't have any feedback from MirrorSync except what I wrote above and that's why I'm sticked with the issue.  

Link to post
Share on other sites

Try creating a new blank FileMaker database. Write a single script, with a single script step, Insert from URL. Use that URL and insert it into a text field. Let me know what the result is in the text field. Be sure to run it from the same device same network that you're having problems with.

Link to post
Share on other sites

Dear Jesse,

Sorry for coming so late. Struggling to install old machines to test them and make sure problem was not an hardware issue.

I did you what you asked and I got below feedback 

image.png.f54287b1add25447b7862cc4aee0acfd.png

The new information is for me is "Missing Session ID".

Other information, is that I installed FMS19 (I was running FMS18) and 3 different machines and installed MirrorSync on all of them and, result is exactly the same. 

I would say that problem is coming from FMS but I don't understand why I can replicate the same error on different computers. Also, I used a new download if MirrorSync 6.12 (just in case) but no change. 

The first installation on december was easy and really straight forward so, I don't get what I miss here.

thanks for your support

Ian 

Link to post
Share on other sites

Jesse, 

FInally, I've just managed to get synchronisation works again. I needed to remove all MirrorSync Material (Scripts, Table and Layout) and reinstall them. Now it's working smoothly. Apparently, after an issue on our database, something went wrong with MirrorSync Material (records ?) but I don't know what. However, if you need a copy of one of our backup, I can send you by mail.

kind regards

Ian

Link to post
Share on other sites

Hello Ian,

We too also started to see this issue and the exact same message when my users are on the same Lan as the FMS server and MS server. However if they connect externally than the sync can will work.

Funny enough if they use FilemakerGo 18 there is no issue. (I sent the users the same file and tested on the same iPad). FMGO 19 same error message including the move to a better coverage area. Confirmed both versions of FMGO where on the LAN for the tests. FMGO19 has not been updated for 3 months now so that can be ruled out. The only things thats happened to us was a WINDOW update ( :( ). and because I am not a network wizard this has me baffled too. 

I just wanted to chime in as your not alone on what you experienced, and think maybe you got lucky

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Who Viewed the Topic

    2 members have viewed this topic:
    tv_kid  anteas 
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.