Jump to content

FMS24 not starting on boot


Recommended Posts

Wow, no posts in this category yet.  Surprising.

I've been playing with installing FMS24 on Ubuntu 22.04.3.  I first tried an upgrade on top of the existing FMS23 install, because our IT guy said we should learn if we could.  The install seemed to go fine.  The admin console launched and things seemed fine.  I saw something about rebooting to make the settings persist, so I did that, but FMS did not come back up with the system.

I then tried doing a `sudo apt remove filemaker-server` and a fresh install, but experience the same behavior after reboot.  I don't see any instructions about making FMS start on boot, so I thought the installer was taking care of all that.  Am I missing something?

I should mention that the server is on an internal network with no access to the Internet.

Link to comment
Share on other sites

  • 1 month later...

I downloaded the most recent installer package (21.0.2.202) and ran the installer.  Everything worked nicely.  Running `ps -A | grep fm` showed lines for "fmshelper", "fmsib", "fmserverd", and "fmsased".  Apache was also running.

To see if it would come back up after a power glitch, I did a `sudo reboot now`.  The FM server did not come back up.  I thought I must need to manually set them up using `systemctl enable`, but the system seems unable to find the services.  If I try `fmsadmin start server`, the command returns `Error:  10007 (Requested object does not exist)`.

Any ideas?  The FileMaker installation documentation simply ends after telling you to run `ps -A` to verify that the installer worked.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.