Jump to content
Sign in to follow this  
davest

Relationships disappear

Recommended Posts

I run a multi-user system using FMServer 5.5 on Windows NT 4.0 and all of a suddenly the relationships disappear from a file at the core of my system. The file is otherwise unharmed and the service does not go down and there is nothing bad showing in the Application (or system logs).

Has anyone come across this problem?

Do you have a solution.

Could it be:

outside influences on the HD

corrupt data

corruption on a layout?

Help?

Share this post


Link to post
Share on other sites

Hi,

From what you have said in your post in sounds as though this has happened on more than one occasion.

If this is the case the cause could be that your database has become corrupted. Try using the recover command in FM and see if this helps.

Ed.

Share this post


Link to post
Share on other sites

Just warning -- after recover do not use that database.

Create new clone and import records into new clone.

Now, how the relation disappeared and where?

It also looks to me like you are crossing files from server and local from local hard disk.

Share this post


Link to post
Share on other sites

Hi Eddy

Thanks for that I'm afraid we tried that with no luck what we normally do is import records into a cloned copy of the file on matching names. Unfortunalely this takes 2 hours on our database using a fast machine.

I am currently rebuilding the file getting rid of 5 years of accumulated fields, scripts,forms and reports (and relationships!)

But I was wondcering if I have missed anything.

Thanks

Share this post


Link to post
Share on other sites

Simple stuff first: check that the key fields on both sides of the realtionship are set to the dame data type (text, number etc).

Data type mis-match leads to some very peculuar and intermittent rlationship problems.

Then again, you mentioned you're cleaning up fields.... open the relationship definition and check that it doesn't have a deleted field (it'll appear as <field missing>) in the relationship sort option. This has caught me in the past, and LiveOak too.

Share this post


Link to post
Share on other sites

Thanks for that Vaughan I think the relationships are matched but I will certainly check them.

The secnario is think looking at a relationship screen full of links and then the next second the screen is blank in working hours when everyone is working.

I am in contact with Filemaker about this problem!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.