Jump to content

newbie at networking, several questions


veganboyjosh
 Share

This topic is 6513 days old. Please don't post here. Open a new topic instead.

Recommended Posts

here's the basics.

we have the host machine, runng fmp 5.5 on xp.

we have a laptop running fmp 5.5 on windows 2000.

our solution consists of about 8 files, linked thru various relationships. i'm not sure if this matters, but they are of modest size, the largest of the files currently has around 2000 records in it, with about 200-250 per month added.

i've just begun to learn about how to network these two together, and from my understanding, i don't want to use the shared folders to have mult-user access to the files. this apparently just seems to either make it not possible to open the file from the 2nd to open the file, or it allows the two computers to alter records--or even the same record--independantly. i'm not sure how the latter works, which file is saved, etc...but that's what appears to happen.

right now i'm in the planning stages, i'm using dummy files to see what works or doesn't, i really don't wanna risk all that data.

anyway, if i'm not using the shared folder of windows networking, how do i connect the two? i know it has something to do with tcp/ip, but i really don't know much about this stuff.

can someone help me, please? if nothing else, point me in the right direction and tell me what to search for?

thanks in advance...if there's any other info i need to post please letr me know.

josh

Link to comment
Share on other sites

Hi Josh:

You got the one important thing down - don't access the file from a shared file!

First and foremost, the manual is an excellent place to find out all the info on doing this. Also the FileMaker Help. Search for "networks," I'll give you the short version:

1. Set up passwords and privledges on the host files.

2. Ensure you are using a common network protocol on both remote and host machines. Set FM to use this protocol. TCP/IP is best probably for you. Open the files in the host computer. Go to File/Sharing on each file you wanna host. Click the Multi-user radio button on those files you want to host and show. Click Multi-user Hidden for files you want to host, but not show up as an option to open for the remote user.

3. Ensure the remote user is on the same local network. Open FM and go to File/Open Remote. Select Local Network and the host pc should show, with the available files below it. Select a file. Enter password and it should work - - unless I left something out! which is possible cuz my brain doesn't work like it used to!

That's why reading the manual is better.

Link to comment
Share on other sites

kenneth,

thanks for a speedy reply.

yeah, i did (most of) that already. the files are set to multi user, the passwords are set up. but when i go to open the remote files, there are no hosts listed. i tried using the specify host option, and entering the ip address from the host computer, but to no avail.

btw, i know the network is working because i can acess the shared files and transfer stuff back and forth...

thanks in advance...

Link to comment
Share on other sites

Well, shoot.

I think I've done all I can from here. Go through the manual and check everything step by step.

If you can, make the host a publically available IP and see if you can connect to it using the public IP, just to see if it's some internal network problem.

Sorry. Perhaps someone else has more suggestions.

Good luck.

Link to comment
Share on other sites

  • 4 weeks later...

well, i was trying to use the same software/serial on both computers, i guess if this is to work i'll have to kick down and get another copy. but like kenneth said, shouldn't i be able to at least look at the host's files? not nevcessarily open them, but have them as an option? i can't get that to work.

i tried specifying a host myself and entering the ip address manually, fropm the hosts window, but it shows no files available. and when i click on local hosts, nothing shows up at all.

oh well.

Link to comment
Share on other sites

  • 2 weeks later...

This topic is 6513 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.