Jump to content

Word wrap in text fields of converted files


redbuffalo
 Share

This topic is 6702 days old. Please don't post here. Open a new topic instead.

Recommended Posts

  • Newbies

I'm having problems with word wrap in text fields of some of my FM6 files that were converted to FM7. Instead of occurring only between words, as they correctly did in FM6, line breaks now occur either within words or at word spaces, depending on when the maximum allotted number of characters per line is filled up. The problem seems to occur with files that were created from FM6 and FM4 templates. Changing fonts and fiddling with Alignment, Indent, and Line Spacing in the Paragraph window don't help. I'm baffled. Can anyone suggest how I might fix this odd behavior and prevent the unwanted breaks within words?

confused.gif

FileMaker Version: 7

Platform: Mac OS X Panther

Link to comment
Share on other sites

It sounds like non-breaking spaces have been entered into the fields. ON a Mac these are Option-Space characters. Try replacing them with normal spaces.

Link to comment
Share on other sites

  • Newbies

Thanks, Vaughan. Reading the threads I see how active you are in helping others. Unfortunately, your suggestion doesn't work in this case. These are not non-breaking spaces. I confirmed this by pasting the contents of one of the text fields into Word and analyzing the word spaces by clicking the Show/Hide [

Link to comment
Share on other sites

  • Newbies

Thanks, guys for this nearly miraculous and very simple solution to the text wrap problem. I had been tearing my hair out trying to fix this since upgrading to 7. The thing I don't understand is why Filemaker does not turn on "Use Roman Line Breaks" as a default when you buy the software. Such rules have been in effect in every version of FM since Version 1. Seems pretty arcane to make puzzled users figure this one out by ourselves!

FileMaker Version: 7

Platform: Mac OS X Panther

Link to comment
Share on other sites

"The thing I don't understand is why Filemaker does not turn on "Use Roman Line Breaks" as a default when you buy the software."

As far as I know it does... were the old files originally created in a localised version of FMP?

Link to comment
Share on other sites

  • Newbies

I haven't researched this thoroughly, but for all of my FM6 files that had been created from FileMaker templates "Use Roman Line Breaks" was turned off during the conversion process to FM7. Old FM6 files that I created from scratch had "Use Roman Line Breaks" turned on during conversion. Go figure!

Additionally, all new files that I create in FM7 have "Use Roman LIne Breaks" turned on by default.

Link to comment
Share on other sites

This topic is 6702 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.