Jump to content

Auto Update a Lookup?!?


Locke
 Share

This topic is 6500 days old. Please don't post here. Open a new topic instead.

Recommended Posts

I've got 2 files I've created a relationship between. The main file has one look-up field, a phone number which is auto-entered when a name is entered in the main file. I would like to add a look-up for an e-mail address as well, but this has not been an existing field.

I've added a new e-mail field (text) to both files, created the look-up, but I can only get the e-mail field to populate in my main file if I enter the name. So, the problem, friends, is that existing records don't execute the auto-enter for the new field. How do I make this work globally/automatically without going through each record and updating the names one at a time? (I hope that made sense)

FileMaker Version: 6

Platform: Windows XP

Link to comment
Share on other sites

Lookups are designed to update only when their key field is changed or a Relookup is performed. So run a Relookup in your name field, and you will update all found records.

Note: auto-enter calculations perform similarly, except they are only entered once, when a record is created. If you add an auto-enter after records have already been created, then you must perform a Replace on them with the auto-entry calculation.

Link to comment
Share on other sites

Thanks for the tip Queue,

I'm a relatively new user (intermediate I guess). How do I perform a Relookup? I assume its a Script calculation, but I can only write basic stuff at the moment and I don't yet fully understand FM syntax yet. Could you maybe give me a little more specific direction (calculation commands, etc.)

Thank you much!

Link to comment
Share on other sites

Well, it sounds as if you're only wanting to relookup the existing records for the new field you added. To do that you'd first put your cursor in the name field, then select Relookup from the Records menu.

To script it, you'd use a Go to Layout [layout containing the name field], then Relookup, click the Perform without dialog checkbox, and Specify the name field.

Link to comment
Share on other sites

This topic is 6500 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.