Jump to content
Sign in to follow this  
JerrySalem

I thought it was simple, finding quotes

Recommended Posts

Hello all,

as the subject said, I thought it would be simple but...

I have a field that I imported from excel. The values of these are, for some reason in quotes. They need to be removed.

I would like to ultimatly do a find, to get all the records that have a double quote. Then do a replace to remove the double quotes.

First I tried puting just a double quote, then

putting the double quote in double quotes,

then putting the double quote in single quotes,

then putting a single quote in double quotes ( I was getting desperate at this point)

So I must ask the experts!

tia

Jerry

Share this post


Link to post
Share on other sites

Do a replace (on a backup!) using the Replace with calculkated result option, where the calculated result would be:

Substitute(textfield, """")

Note the doubled double-quote marks, it's not a typo.

Share this post


Link to post
Share on other sites

Woops! shocked.gif" border="0

quote:

Originally posted by Vaughan:

Substitute(textfield, """")

I think you'll need to finish the function:

Substitute(textfield, """","")

Or as an alternative, assuming no other non-indexible characters at the beginning or end of the data in each field:

= LeftWords(textfield, 9999)

Good luck

Share this post


Link to post
Share on other sites

Quite right! Substitute(textfield, """", "")

Share this post


Link to post
Share on other sites

Thanks a bunch to all of you. The Substitute command worked fine. I did a replace over the whole dataset. You solved my imediate problem or removing the double quotes.

However just to cover all the bases, we didn't get to the question.

How do I find fields with a double quote in them? That still dosesn't work!

Jerry

Share this post


Link to post
Share on other sites

Hi Jerry,

A find on *"""" (shift-8 followed by four double quotes) should find a field with double quotes.

Note however that double quotes are different characters than "smart quotes" (the curly variety of quotes). My recommendation would be to eliminate all smart quotes from your FileMaker diet -- they're basically evil. wink.gif" border="0

First, turn off the smart quotes in your document preferences. Then if you already have them in your field data, use Substitute() to replace them with regular quotes.

Share this post


Link to post
Share on other sites

In future, import your file as tab delimited rather than comma delimited. That should prevent all the quotes in the first place.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.