Jump to content
Sign in to follow this  
FMDuck

Trouble connecting from client end

Recommended Posts

I've been trying to connect to my office with FM 7 from my home PC.

I cannot access my office or my customer's servers (OS X).

Currently I can access the hosted files across the LAN within the office.

I'm running Server 2003 without IIS.

The firewall is down on both ends - I can ping the router.

Port 5003 is open locally.

Port Forwarding is set to the server's local static IP

I have the same problem regardless of hosting with FM Pro or FM Server.

I have not tried web publishing yet.

(and again, I also cannot access other FM Servers)

Am I forgetting something?

Any ideas? - Thanks.

Share this post


Link to post
Share on other sites

Hi,

I'll echo the situation above for the most part. I'm hosting a FMP7 file on my pc/xp. The 5003 port has been cleared or open on my pc and the client's. I informed network administration about opening port 5003 on our router or whatever and they assured me it was done. The client does a Open-Remote, sees my IP address, clicks on it, sees the file, clicks on it but gets a message back the the file is not open. (BTW, it's open.) What gives?

Share this post


Link to post
Share on other sites

Veronica,

It looks like you may or may not have a similiar problem. I ended up having a bad router and a software firewall problem all at once. The router wasn

Share this post


Link to post
Share on other sites

Howdy! Jeff and Veronica might have solved their problems by now, but for folks still trying to connect to their db's from home but not having luck, here are some tidbits/info that may be helpful (some of which has already been mentioned) that I used to tell folks for FM4-6 (but I'd assume FM7, too) ...

AT THE OFFICE...

(1) computer w/FMP on a fixed IP address**

(2) FM running with db open and set to be shared

(3) firewall allows port 5003 traffic (if applicable)

** if you are using internal local network IP addresses (e.g. 192.168.x.x, 10.0.0.x, etc.), you may have to set your router to do PORT FORWARDING so that any :5003 traffic is directed to correct computer on your network.. just as Jeff Duck did

AT HOME...

(1) run FM and use the OPEN > HOSTS or OPEN REMOTE feature and type the IP address of your FM server (or the IP address of your router if you use an internal IP address local network)

TROUBLESHOOTING...

* make sure both comptuers have valid internet connections

* turn off firewalls temporarily in both locations to see if they are interfering somehow (firewall behavior can be implemented on a computer-by-computer basis or for an entire network at once or both)

* if you use DHCP and did not use a static IP address for you FM server computer, verify the IP address did not change

* if you configured your router for port forwarding, check both the port number and IP address again

* if you are using a wireless configuration at the office, you may be creating a wireless network that is different from your wired network; if so, change your wireless to use your router's IP addresses or change your wireless router (macs = base station) to also do PORT FORWARDING to the wireless server

These are just off the top of my head, but they may help some folks out there looking for places to start.

--ST

Share this post


Link to post
Share on other sites

I'm having a similar problem. When I open the Filemaker PRO 7 application and click on the remote I get this error: Filemaker cannot share or be a client of a file because the networking stack cannot be initialized. Any suggestions? Be kind, I'm not a novice on the computer or Filemaker but am a novice on networking issues. Thanks.

Share this post


Link to post
Share on other sites

I've never seen this error, but I would assume you have a memory problem. Are you running on Win 2000, XP or OS X? If you are on the right OS I would assume you are also running TCP/IP, but you may want to check that as well. If all of that is OK, maybe consider testing your memory, making sure you have plenty of drive space, your HD is defragmented and you have a good physical network connection.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.