Jump to content

Filemaker Site Assistant


This topic is 6620 days old. Please don't post here. Open a new topic instead.

Recommended Posts

I've oringally posted this in the Filemaker Online section of this forum but have recieved 0 responses for the last couple days. Hopefully regulars in the section will be able to help me out. Here is a link to my original post.


Here is the content of my post also..

I'm not sure if this is the right forum to post this in, but here we go. I managed to get Filemaker Site Assistant to notice my database as being accessible. When I click on the db, it asks for a username and password.. I enter the information and I get access denied. I've tried resetting the password, all that jazz, and keep getting access denied. Any information would be appreciated.

EDIT: I guess it will be a good idea to let you know the background of my setup. I have filemaker advance server 7 running on a mac g4. I am putting up a webserver on windows 2003. I installed the filemaker web module and tools so that I can have the web server access the filemaker server. I added extended prvialedges to the database for xml and xslt and it shows up in the filemaker web administrator area. I'm just having trouble using Filemaker Site Assistant. Hope this little bit of information is useful.

An update on my progress:

I found a thread in the fmforums about someone who was having the same problem. Here is a link to the thread: http://www.fmforums.com/threads/showflat...true#Post138567

I tried creating a user account on the database that has just read only access and I'm still having the problem.

Link to comment
Share on other sites


The must use the admin account and password. You need to have full access.

This works for me.

If you cannot access with this, try to make a test file and connect.

If that's no problem, I guess you need to repair your file, using filemaker.

;-) Claus

Wow, finally I got a response, thanks. However, I'm still not able to connect to any database using Site Assistant.

I created a new database from scratch. Added in the extended privaledges that are necessary for Site Assistant to see the database. I added a user to the database that had full access privaledges. I headed over to the web server, fired up Site Assistant, saw the new database that I created, and bam, same error. This is a brand new database and I can't even connect to it.

Is there a problem or anything with going from a Windows web server to a Mac filemaker server? I'm not sure what to do next. Any information from anyone would be helpful. Whether its the filemaker server that isn't configured correctly or the web module on the web server. I'm not sure.

Link to comment
Share on other sites

Yep, I've tried creating a new user and giving it full access to the db and still nothing.

I'm not sure if its related or not, but when I open up the database in the filemaker client (ver 7), I can just put in a password and leave the username blank, and it gives me access to the db. I've tried this on the web server, but still no luck.

Link to comment
Share on other sites

Here's an update on my progress with this problem. I installed Filemaker server on a Windows machine and created a new database called testxml. I added fmxml and fmxslt to the database so that they show up as available for web publishing. I created a new user called test and password test and gave it full access.

I then went on to the webserver and configured it to connect to the new Windows Filemaker server. The database page displayed the testxml database that I just created. I loaded up Site Assistant to connect to the database. Entered localhost as the server, hit connect, testxml came up. I click on testxml and it asks me for a username and password. I put in test/test, and bam, still Access Denied.

Since I've tried it on mac and pc, I've found out that its not a communication issue between mac and pc. Is there a configuration that I am missing when setting up the Filemaker server or configuration of the web module?

Link to comment
Share on other sites

...that's one hard nut.....

Have you tried to run filemaker site assitant on the machine that runs fm server ?

;-) Claus

Yep, I just tried and it didn't work frown.gif

I did notice a weird error when I load up the testxml database in Filemaker Pro. I get the error, "Filemaker cannot share files because another user is already sharing files using Filemaker Pro on this computer." I stopped the Filemaker server service to see if that has anything to do with it, and I still get the error. Is this contributing to the problem with site assistant?

Link to comment
Share on other sites

This topic is 6620 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.