Jump to content

script step to run another FM7 runtime application

This topic is 6684 days old. Please don't post here. Open a new topic instead.

Recommended Posts

I'm not having any luck satisfying Dev 7 (MAC OSX).

I would like to run another FM7 runtime solution in the background by starting it from a script step in an 'active' runtime solution.

I've tried various forms of 'send event' and am about to conclude that's not the way to do it.

How do I get the other runtime solution to run from a script step?


Link to comment
Share on other sites

I just tried this using Dev7v3 on MacOS X 10.4.2.

I made a runtime, then I made another runtime that opens it in the background via a script.

I just used the send event script step like you mentioned. I specified the "open application event" and then specified the previously bound runtime application. Then I bound the new runtime, launched it, and ran the script. The other runtime launched and remained in the background. You can specify whether to leave it in the background or bring it to the foreground.

Link to comment
Share on other sites

I'm on OSX 10.3.9; FMdev7.0v3. When I do 'send event', select 'open application', and 'open' the deired runtime application it seems to be happy. After doing this, the script step looks like:

send event["unknown";"aevt";"oapp";""]

Then when I execute the step, I get the message:

'The file "" could not be found and is required to complete this operation'. It seems to ignore the chosen application.

I'm also having trouble on Windows XP (I need the application to work on both platforms). The 'send event' step works fine when executed from FM7. But after creating the runtime application, the 'send event' seems to be ignored. Nothing happens - the other runtime does not start. I've done an error capture around the step, but no error is detected during the 'send event'.

I'm frustrated!!

Link to comment
Share on other sites

Mine says:

send event ["WhateverApplicationIChose";"aevt";"oapp";""]

If you choose another application, does it still say "unknown"?

It seems like the application is not being selected properly, but I've tried it on two different Macs now, and I've opened many scripts and applications with send event on windows... I'm not sure what's going on with your setup.

Link to comment
Share on other sites

if I choose one of the 'standard' applications in the application folder, it works properly. Just seems to ignore the FM runtime solution even though it accepts it as a valid choice when 'specifying' the application.

Is there something 'different' about the way FM marks a runtime solution as an 'application' that might cause it to be ignored (the Finder and get info clearly identify the runtime I'm trying to select as an 'application')?

I've tried this on a new database and on 2 different MACs (both on 10.3) with the same results.

Link to comment
Share on other sites

I tried it with a couple of runtimes and it worked OK. Maybe you could try "open document" and then have it open the primary file used by the runtime. That should cause the runtime to launch, assuming you gave the files a unique extension.

Does the runtime launch when you double click it normally?

Can you use an Applescript to launch it? Or a shell command?

For instance, typing this command in the Terminal will open Address Book:

open Address Book.app

You could just have send event launch the application using applescript directly, or using this terminal command wrapped within the "do shell script" applescript command.

Link to comment
Share on other sites


The key to the problem:B)

"...assuming you gave the files a unique extension."

Thank you! I was binding both solutions with the same extension. Now with a unique extension for each solution, the world is wonderful!! I can't wait to see if that solves my XP problem as well (I'm sure it will, but that will have to wait until tomorrow).

Link to comment
Share on other sites

This topic is 6684 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.