Jump to content

Filemaker slow to open


 Share

This topic is 5713 days old. Please don't post here. Open a new topic instead.

Recommended Posts

I have been using FM Pro 4 for several years for managing direct mail lists for local charities.

Suddenly last summer the program began taking up to 3 minutes to open. At first I thought maybe it was time to upgrade to a newer version and I purchased FM Pro 6. But it was also taking 3 or more minutes to open.

I take very good care of my computer system, regularly run anti-virus, spyware, and other maintenance software. Also keep system defragged and backed up. My system hard drive has 75% free space and plenty of memory.

Windows Registry is up to date, defraged and organized.

Filemaker is the only program that has this problem. All other functions of the program are working just fine but it would be nice to get it to open normally like it used to.

Any suggestions would be appreciated. I am out of ideas.

Link to comment
Share on other sites

Believe it or not, running virus software over open FMP files can cause corruption. Set up your virus software explicitly NOT to scan the FMP files.

Check the size of your file... are they near their file size limit? Depending on the vertsion the limit is either 32MB (yes, just 32MB) or 2GB. I know that fp5 files are 2GB, not sure what fp3 files are.

Also check the windows temp folder, if it is full of files then delete them.

Link to comment
Share on other sites

Thanks for your suggestions. I will look more closely at my virus software but I am pretty sure that I have tried turning off all of the spyware and virus software before attempting to open Filemaker with no improvement.

None of my data files are that large. And my temp files are usually cleaned with regular maintenance.

It is not the data files causing the problem. I used to open the program by clicking on the particular file.

When this problem started, I began just opening Filemaker first without selecting a file. That is when I realized the problem is with Filemaker itself. Both version 4 and 6 are doing the same thing.

But on my laptop computer they open normally without any delay.

Link to comment
Share on other sites

Judy,

It's been a couple years since I worked with an older version such as Filemaker 4.0 but I seem to recall that those old versions of really got themselves attached to their printers. Attached to the point where if a printer was deleted, the system would hang or seemingly take forever to come up. You would naturally think that printers wouldn't come into play unless you were actually attempting to print something yet I seem to recall that the simple act of opening the FM application after a printer had been removed would freeze the system.

I believe the problem could be solved by either uninstalling and reinstalling Filemaker or by deleting the Windows registry key that still contained a reference to the departed printer.

I'm sorry I can't be of more help but take a look at the Windows registry settings concerning Filemaker and maybe you will see an old printer listed there.

Edited by Guest
Link to comment
Share on other sites

Wow! Who would have thought about the printer problem. Yes, last summer my workhorse 5 year-old lazer printer finally failed and I replaced it. Will check out your suggestions.

It could be what is effecting the FM 4 version but I would be curious if it was effecting the opening of the FM 6 version since that was not installed until after the problem began.

I installed the FM 6 version on a separate hard drive because I wanted to work with that updated version some before I began using it with my important data files.

I am an "old dog," cut my teeth back in the 1980's on CPM operating systems and really take my time upgrading any software. If I had a choice, I would probably still be resisting Windows.

Link to comment
Share on other sites

I have now tried everything you suggested. Edited the Registry for all references to old uninstalled printer and completely uninstalled both FM 4 and FM 6 and tried reinstalling them.

Problem is still there. Ehen I click on it, the Logo appears with a message "initializing" and then "loaded" but 3-4 minutes pass before the program actually opens and is ready for use.

Link to comment
Share on other sites

I have now looked at all the suggestions and tried all the fixes so far but not getting anywhere.

Still looking for concrete solution. Clearly it is a problem with my Primary computer system. As the problem does not exist on my laptop or other computers.

Link to comment
Share on other sites

Another thought; how about fonts? Do you possibly have some odd fonts on that system or maybe some common fonts that are missing? When v3 opened I seem to remember a varying number of fonts loading depending on which PC I was using. I'm kinda grasping-at-straws here.

Link to comment
Share on other sites

Thank you for all your efforts. I am pretty sureit is not a problem with fonts since there were no changes made to fonts just before the problem started last summer. Also I have now twice deleted all Filemaker Programs and installed them fresh (making sure that I had shutdown the system and restarted after uninstalling programs.

At the moment I only have the FM 6 installed and when I clicked on it this morning I watched...when the screen logo showed program was loaded but had not yet displayed on the screen I went to Task Manager and watched to see how long it would be before the program showed up there.

I was thinking maybe the program was loaded in memory and the delay was related to settings for the flat screen monitor. But it took 3-4 minutes before the Task Manager showed the program running.

I am convinced the problem is somewhere in the Windows Registry so I will keep trying to find it there. Thanks again for all your efforts.

Until I find a resolution, this old (64 years) dog will just have to develop some patience. :D

Link to comment
Share on other sites

I have seen such problems caused by corrupt fonts and also with corrupt preferences (on the Mac anyway.) It may not be the same with Windows, but I'd try dumping the FileMaker Preference files and troubleshooting the fonts on the computer.

Link to comment
Share on other sites

I tried deleting the fonts in the FileMaker Folder (then rebooting the system before opening FileMaker again) and the problem still exists. I'll try working on the preferences next.

However, I have only a few preferences indicated in any of my data files most are the defaults that come with the program. The only changes I make is to identify which layout to open when the files is opened.

Since the problem arises without opening any specific file, I doubt that preferences is the issue. But appreciate your input.

Edited by Guest
Link to comment
Share on other sites

This topic is 5713 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.