Jump to content

Handmade vs. Wizard?


eljefejb
 Share

This topic is 5657 days old. Please don't post here. Open a new topic instead.

Recommended Posts

Hello -

I've been assigned to create some reports from a simple FM file that my supervisor gave me. I created a report layout that uses meeting dates as a break field, displays the items reviewed on that date, then shows a summary field (count) of the items in the trailing sub-summary section. This layout works great and is nicely formatted, so I duplicated and modified it in order to start on a second report. The second report uses manufactured part numbers as its break field, and a "Total Of" summary field in the trailing sub-summary section. This summary field is supposed to display the total of the "Quantity" field for all records in the sub-summary section.

The total quantity by section (part number) field is not displaying the correct value in some cases (shows up as "?") but works fine in others. I know the field is defined correctly, because when I ran through the New Layout/Report Wizard out of frustration and set up an identical report (less my nice formatting), the quantity works correctly. I have gone through each part of the layout definition for both layouts, and they are defined exactly the same. Anyone have any idea why the first one doesn't work? I tested both layouts in exactly the same way... started with all records visible, found the same set, sorted on the same fields, switched to preview mode, etc. The first one doesn't work, the second one does... I don't get it.

I know, I know... the easy solution would be to copy/paste all my formatting from the non-working layout into the ugly one created by the report wizard. It just bugs me when I can't find a reason for something not working correctly. Besides... it's a pain in the butt to copy/paste a bunch of stuff, flipping back and forth between layouts! Any light shed on the matter would be appreciated.

Thanks!

Link to comment
Share on other sites

Oy vey...

After beating my head against the wall for a while more, I noticed that the Quantity field on my original layout was of a smaller width than the one on the layout made by the wizard. Some of the numbers that should be displayed in that field are 4 or more digits long, but the width would only accommodate about 3. "It can't be that simple," I thought. The width of a field should have no bearing whatsoever on the data contained inside. It is just a display property, and the summary should work fine, regardless of the width. Well, turns out I was wrong... expanding the width fixed everything. The summary on my original layout now works fine! Go figure...

Link to comment
Share on other sites

This topic is 5657 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.