Jump to content

FM8 Server no longer run scheduled backups


This topic is 5253 days old. Please don't post here. Open a new topic instead.

Recommended Posts

Hi,

I recently upgraded to FMServer 8.0v4 and to my surprise FM does not make any scheduled backup anymore. when it is time to make the backup, no database will be backuped and the column 'Next Run' for the scheduled task will automatically switch to 'Disabled' yet all the configurations are set to make daily backups.

Please help.

Link to comment
Share on other sites

Hi Steven,

FMS had write privileges to the folder but still could not copy, however when i created a new folder and assigned the same rights, FMS was able to run backups correctly into that folder. Problem fixed, though I still don't understand why the same old backup folder with same access rights suddenly refused to work after upgrading to FMS 8.0v4.

Thanks.

Link to comment
Share on other sites

  • 2 weeks later...

Two possibilities:

1. If this was on an external drive, you need to make sure "ignore prermissions on this drive" is not checked.

2. I think OSX still has bugs with properly showing and changing permissions via the finder. I sometimes have to open & close the "get info" window a few times before the settings seem to "stick". Annoying.

Link to comment
Share on other sites

  • 1 month later...

I am having exactly the same problem...

I have a schedule running a backup to a local firewire drive - this worked fine on Server Admin 8.0v3 but since I have upgraded to 8.0v4 it refuses to backup. It still backs up fine to the main drive though. I have now installed a second local ATA drive on the machine, and enabled the correct FSadmin permissions. The Schedule is refusing to see it as a valid path. My drive is called Drive2 the machine is a G4 mac running 10.4.7. My path is filemac:/Drive2/ Even just trying that and not the full folder path is not validating. This must be a bug. I have logged it with Filemaker.

Link to comment
Share on other sites

Filemaker fixed this in 8.0v4. If the server cannot find the path, it no longer disables the backup. However, I think that there could be a lot of systems out there that have upgraded to 8.0v4 and use a drive other than the main system drive. You now have to check the dates (good practice anyway) rather than making sure than none of your scripts have disabled themselves.

Link to comment
Share on other sites

Is working now after installing the second ATA drive. After a few restarts it finally started recognising a Valid ATA Path. I had not changed the directory structure or schedule paths. It also said that some of the firewire paths were valid but not others. I don't know what the logic is there but it was very frustrating. In summary, restarting with the drives attached (or ATA internals) seems to give you the best chance of getting a valid path.

Link to comment
Share on other sites

  • 3 weeks later...

Let me add one more solution. I was having a similar problem with a new backup location. After insuring that the folder in the path had proper permissions, and opening and closing the Get info box to be sure the permissions "took", and even restarting the server, I finally tried changing the permissions on the parent folder of the backup folder. That was the trick. My theory is that FMS actually replaces the backup folder specified in the path so it is important that the parent folder have write permissions enabled. (But then again maybe it's a bug.)

Link to comment
Share on other sites

  • 1 month later...

One more possible problem to add to the list...I fixed all the permissions on my drives and folders but I neglected to remove or change permissions on the previously backed up files that were inside the folders. (I was moving FMS from one machine to another and had folders for each day of the week where the backups were supposed to overwrite the previous Monday's/Tuesday's/Etc. files the next week. I copy each Friday's backup to a weekly backup folder for permanent archiving). Emptying the folder allowed the backup to run and subsequent backups overwrote the old files as they were supposed to.

Before I fixed the problem, I would run the schedule and it said "Running" for just a split second and nothing backed up.

Link to comment
Share on other sites

  • 7 months later...

For the life of me, I cannot get my files to backup to my Firewire drive. It's driving me nuts. It worked at one point, and it doesn't now. So I backup locally, then have a cron job moving the files. But that local backup is dog-slow and my users are complaining.

I've checked and rechecked the permissions, checked for the "ignore" box to be unchecked, restarted, etc. No luck. My permissions are:

drwxrwxr-x 2 fmserver fmsadmin 68 Jul 6 08:34 hourly-direct

I've also tried it as:

drwxrwxrwx 2 fmserver fmsadmin 68 Jul 6 08:34 hourly-direct

and still, I got "not a valid path."

Please help! I'm going nuts on this one!

Link to comment
Share on other sites

I called FMP. $3/minute to get an answer here.

But first, I filled out a whole email support form, clicked to submit it, and then got a message that they don't do email support. So why have the form? To waste my time?

Link to comment
Share on other sites

This topic is 5253 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.