Jump to content
Sign in to follow this  
simon clarke

Removing spaces from table names

Recommended Posts

I'm new to Filemaker and trying to access a filemaker database via ODBC in order to migrate some of the data into a SQL Server database. Unfortunately, the database has both table and field names that contain spaces.

I was able to edit the field names to enable them to be read via ODBC (in Filemaker Pro I used File>Define>Database to rename the fields, replacing spaces with underscores), but I can't seem to do the same for the table names.

Can anyone advise me how to change the name of a table (without losing the existing data) in order to make it available via ODBC? As I say I am completely new to Filemaker so I don't know if this an easy thing to do or not.

I have tried changing the table name using File>Define >Database, and also tried renaming the fp7 file, but my SQL query still just gives a "table not found" error.

Thanks,

Simon

Share this post


Link to post
Share on other sites

Once a table is created, it will put a table occurence of it on the relationships graph. If you change the name of the table, it does not change the name of the table occurence. Try going to the relationship graph and change it there as well.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.