Jump to content
Sign in to follow this  
Attila_G

FMSA9 / IWP / Apache2 Problem on Mac OSX 10.4

Recommended Posts

Hello everybody

[First of all: sorry but english is not my native language...]

I have a Mac running 10.4.11 and Apache 2.2.x (also tried with 2.0.x). This config works fine. On this machine I installed FMSA9. I can access the DB with a FM client without problems. When I try to activate IWP I always get this error:

Web Server Test Failed. Return code = false (or -1)

After two days of frustration (searching the whole web for a solution and trying all possible settings) I have still not found a way to run IWP and a custom Apache2 server...

To identify the problem I tried:

- OS X Server 10.5.x with the built-in Apache 2 server -> IWP works fine

- OS X 10.4 with built-in Personal Webserver -> IWP works fine

So I found this workaround (for 10.4);)

My custom Apache 2 server is now listening on port 80. At the same time I run the built-in personal webserver, listening on port 591. FMSA9 IWP is now also configured on port 591.

It's just a workaround... I still can't believe that FMSA9 is not recognizing my Apache 2 server as it is no more a new product :-(

If someone found another solution to this problem, please let me know!!!

Regards

-- Attila

Share this post


Link to post
Share on other sites

When using OS 10.4.x you're supposed to use Apache 1.3. When using 10.5.x you can use Apache 2.

Check the technical specifications at this link.

I have a number of client installations running in this fashion, and all work fine for IWP.

Steven

Share this post


Link to post
Share on other sites

Yes, I know this requirements. But it says "minimum" Apache 1.3. Minimum for me means that Apache 2 should also work as it does on 10.5. What should be the technical reason for not working?

-- Attila

Share this post


Link to post
Share on other sites

The Leopard and non-Leopard versions of FileMaker Server 9 have different requirements. On OS 10.4.x, Apache 1.3 is the correct version to use. On the OS 10.5.x of FileMaker Server 9, Apache 2.x is required.

Steven

Share this post


Link to post
Share on other sites

I am using a MAC X Server with Apache

When i open the start page

http://XX.XX.XX.XX/fmi/iwp/cgi?-db=XXXXXXX&-startsession

It forwards me to

http://XX.XX.XX.XX:16080/fmi/iwp/res/iwp_auth.html

I had to open Port 16080 in my firewall

Once I did I was able to use IWP.

Share this post


Link to post
Share on other sites

Hi Guys,

I have:

OS X Server 10.5.6 on INTEL CORE 2 Duo.

FileMaker Server 9.0.3 326, the 10.5 version installed.

I cannot Get IWP to start.

The 'Enable Instant Web Publishing' checkbox in the 'Web Publishing - Instant Web Publishing' Tab is always grey'd out.

I have ports 591 (TCP & UDP in), 16080 and all FileMaker Services allowed in the FireWall settings of OS X Server 10.5

What am I doing wrong?

Edited by Guest

Share this post


Link to post
Share on other sites

IWP is only available on FM Server ADVANCED - do you have a licence for the ADVANCED version?

Share this post


Link to post
Share on other sites

Wrong version of Server. You need Server Advanced.

Also, the web ports are managed from the standpoint of Apache, not of FileMaker Server.

And there are other ports you need as well. See thefmkb.com/6427 Tech Info on this.

Steven

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.