Jump to content
Sign in to follow this  
krempch

FM8/9 - Save File As grayed out for [Full Access] user

Recommended Posts

I am attempting to clone a DB using File | Save Copy As menu.

The selection is grayed out, even though I am [Full Access] account.

Do I have to have all other users off the system before it will enable? If I look at a backup copy with same permissions, the menu selection is available.

Thanks.

Share this post


Link to post
Share on other sites

I found my answer -

The option becomes available when I am the only one on the DB.

I opened a backup copy and the option is available.

Share this post


Link to post
Share on other sites

No, that's not the answer. You cannot save a copy of a hosted file, irrespective of the number of users connected.

Steven

Share this post


Link to post
Share on other sites

So I discovered this morning after kicking the users off.

I'm making a copy of yesterday's backup and will

try the operation against that locally. (I was hoping to avoid all the overhead associated with that).

Thank you for the feedback.

Share this post


Link to post
Share on other sites

Hi again, Steven:

I was able to clone that file once I put it on my local machine.

I notice, though, that if the copied DB or the clone of it are open, my 'Open Remote File' dialog shows the local machine in the remote host list.

The normal remote host can be selected and will display the files it has in the Available Files pane. The local machine will not display its in that pane if I select it.

Should I be seeing this? Will it be an issue of any sort 'down the road' should I move the new clone to a different machine (the plan), or try to export records from it (this also eventually planned)?

Aim me at documentation if possible. I am looking through the FM9 Server manuals to see what's offered there. Thanks.

Share this post


Link to post
Share on other sites

I looked at the FILE | SHARING options for the file. File sharing is NOT turned on for the file for anything (FM Network, ODBC/JDBC, IWP).

If I turn FM sharing on, the LOCAL PC's name shows as a HOST (as it has since this started).

It now also displays the file name in the Available Files pane (originally the Local PC name showed as long as the file was open, but the file name itself did not display).

With FM sharing turned off, the HOST pane still displays the local machine's (as did originally) name, and the File name disappears from the Available Files List (again, the original situation).

If I select the local machine's name in the HOSTS list, and try to erase the path info for it, there is no option to save this change.

Still looking for the answer ... just wanted to clarify what I am seeing and where I've been looking.

What is set in this file that the Local Machine is displaying? The machine has two other DB on it (which have never been shared) and these never show up in the Open Remote File dialog. It has to be some sort of switch/option that gets set by FM9 Server. Thanks.

Edited by Guest

Share this post


Link to post
Share on other sites

:bang: OK, I put the file back on to the server, opened it (normally), closed it (normally) and then ported the copy back to the Local machine. NO CHANGE in behavior.

Did this to explore whether or not it may have thought the original was still OPEN when the backup I made it from was originally created.

Guess that wasn't the answer.

Share this post


Link to post
Share on other sites

I give up. File is on the server, with FMAPP extended privs enabled, and FileMaker network sharing enabled.

Server Pro 9 Admin Console sees the file, allows me to access it via a remote desktop, allows me to export and import to it. It just DOES NOT light up the protocols like the other databases

in the Administration: Databases list.

:badidea: I guess I'm going to have to use it and pray it doesn't bite us in the butt later. This will be a prayer wasted - these things always bite us later after the data has been carefully entered.

Share this post


Link to post
Share on other sites

Thank you, ts_turtle for the answer.

The refresh button on the database screen fixed the issue.

http://forum-en.filemaker.com/fm/board/message?board.id=us-fms&thread.id=655

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.