Jump to content
Sign in to follow this  
Norvin

Go To Realated Record (external FM File)

Recommended Posts

Can someone please tell why a go to related record script (to an external FM file) works fine attached to a button but if I try to run it as a perform script step, nothing happens. It is the same script. What (obvious thing) am I missing.

Thanks

Share this post


Link to post
Share on other sites

Thanks for taking a look. There’s not much to it at this point. The Data Source is Filemaker. The table reference is MO_MarkerOrder. That is also the name of the target layout of the referenced table. Like I said if I create this script step attached directly to a button it works but if I create the same script step inside the edit script window and attach it with a “perform script” to a button it doesn’t work. If all I needed was a go to related record I’d settle for the button script but I need to build more steps around the go to related record.

Below is the script as it appears in the edit script window

Go to Related Record [show only related records; From table: "MO_MarkerOrder";External;Using layout:"MO_MarkerOrder" (MO_MarkerOrder)]

Share this post


Link to post
Share on other sites

Do you have script execution turned off on the external file? It's part of the privileges.

Share this post


Link to post
Share on other sites

Sorry for the delayed response. The only privilege sets I have for the external file (MO_MarkerOrder) are the default settings when I created it. The only active account is Admin. So, unless I’m missing something, I don’t think that’s the problem.

Let me provide a little more information and maybe give a better picture. I have two FM files. MS_Master and MO_MarkerOrder. Each file contains an external reference to the other. I have some lookup fields in MO_MarkerOrder and they work fine. I want to set a go to related record script in MS_Master that will target the related record in MO_MarkerOrder. If I attach the go to related record script directly to the button, works, no problem. However, if I create the same go to related record script in the Manage Script window and attach it to a button via perform script step, nothing happens. At this point there are no other script steps involved and I also selected the run with full access privileges. I’m baffled.

Hoping someone can show me the error of my way.

Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.