Jump to content
Sign in to follow this  
madwill

Date format problem

Recommended Posts

Hi experts,

I'm a long-time user of FMPro, but untrained and dangerous! Though English, I live in Spain, working in Windows XP Pro (in English) and FMPro 6.0 (in Spanish). I'm developing a (for me) complex sales and invoicing solution for a friend and decided to adapt some ISO starter files from the Scriptology book/CD I bought some years ago. Everything seems to work fine, except that I cannot format the date fields to display (month names) in Spanish, as the user wants on his invoices. The options only allow for English. I've tried toggling things like Use system formats, but to no avail. The Default language for indexing and sorting is greyed-out for some reason, so I have not been able to experiment with that.

I've been toying with the idea of using a calculation to get it to produce the goods, but if there is a solution I've overlooked, I'd be very grateful for your help. If the calculation is the only way, I should also appreciate help with that.

Many thanks,

Madwill

Share this post


Link to post
Share on other sites

Try cloning the files while the OS is set to use the Spanish date format.

Share this post


Link to post
Share on other sites

Thank you for your prompt reply.

Unfortunately, having cloned the 3 files concerned with the OS set to Spanish formats (as it always is), there is no change. The options still only appear in English (e.g. Thursday, 25 April).

Very grateful for any further suggestions.

Madwill

Share this post


Link to post
Share on other sites

Again, many, many thanks.

I'm impressed. But it's not working for me. I've seen that your clone example works great - indeed, I've never had this problem before. But I've checked my OS setting and recloned the files and I still get the date options in English. I attach screenshots of the 2 dialogues. Maybe I've got something else wrong. Otherwise, I think it's my FMPro that perhaps requires reinstalling(?)

Very grateful for your help.

Madwill

shot1.bmp

shot2.bmp

Share this post


Link to post
Share on other sites

What do you get when you create a new file under these settings?

Share this post


Link to post
Share on other sites

That is weird. Although it seems that you *do* get Spanish month names in the 'Custom' section.

Share this post


Link to post
Share on other sites

No, I get a mixture of English months and some Spanish terms like Quarter (Trimestre).

I trust there's a remedy! After all, the FMPro is in Spanish. I have Spanish menus!

Thanks again.

Madwill

shot3.bmp

Share this post


Link to post
Share on other sites

I've never used a localized version, but I don't think the menus have anything to do with this. Since I am not a Windows user either, I'd suggest you explore those settings again, and make sure that the SHORT DATE FORMAT is set to Spanish.

Anyway, if your system is giving you trouble, your friend should be able to clone the files on his/her system.

Share this post


Link to post
Share on other sites

Many thanks. I've checked the settings, double-checked everything, uninstalled and reinstalled FMPro ans *still* the problem persists. So I shall just have to do the last-minute tweaks after installing on his system.

However, my problem remains...

Thanks for your patience.

Madwill

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.