Jump to content

Missing value list and blank name


RioRondo
 Share

This topic is 4309 days old. Please don't post here. Open a new topic instead.

Recommended Posts

  • Newbies

FMP10 mac OS 10.5.8...

I have a value list in a file... that appears to have no name, no value list items and can't be edited or deleted.

What gives?

backstory:

I was updating a file, added a field (number, global) and it needed a value list.

So I set everything up from a client, added it to a couple of layouts, set the value list, then quit out so I could do some stuff with the host machine (compress copies, make backups etc.)

When I reopened this set, that field came up as "value list missing". When I went to layout to reset it... there is an entry in the value lists (only two value lists in this file) but it shows nothing (blank) for a list name, and nothing (blank) for the field values that had been typed in.

Moreover, I am not able to edit or delete it!

So I made a third value list, and gave it the same value list name... and it errored me saying it was a duplicate value list name. So I named the third list differently and set it up on the layouts. It seems to be 'sticking'.

But what on earth happened to the second value list that is and continues to be blank, and I can't edit or get rid of it? It bugs me. I ran recover on a copy of the file but the blank value list remains, and it kicked up no errors.

Any clues?

Thanks!

Link to comment
Share on other sites

That file is corrupted. If you have a non-corrupted backup, I'd highly recommend you go back to it and import any new data.

Link to comment
Share on other sites

  • Newbies

That file is corrupted. If you have a non-corrupted backup, I'd highly recommend you go back to it and import any new data.

Yeah, I suspected that might be the case and swapped in a backup and then made the changes again.

Dang, I hadn't seen evidence of a corrupted file in years... :)

Thanks for the response.

Link to comment
Share on other sites

  • 1 month later...
  • Newbies

I know this is an older thread now, but I just had the same thing happen twice tonight.

I needed to add about 10 value lists to an existing file. Everything seemed fine till I closed the file. When I reopened it, all the new value lists added had no name and no data, and could not be edited, or deleted.

Yes, I was able to go back to a clean copy of the file, but this happened TWICE in a row.

That now is two different files, 3 times.

I was adding the value lists via a client machine, locally hosted on another machine (not through FMP server). THe third try I added the value lists (to a clean copy of the file, of course) directly from the hosting machine, and they stuck (after quit/relaunch).

Is this some kind of glitch? Is it not "safe" or "ok" to add value lists via a client? What about editing an existing list? Anyone know?

FMP 10/Advanced, Mac OS X 10.5.8 on both machines.

Link to comment
Share on other sites

Is the file in a shared folder? I.e. is it possible that someone is accessing it via OS file sharing (Bad) vs. FileMaker's "Open Remote" command (Good). The Bad way will cause corruption.

Link to comment
Share on other sites

This topic is 4309 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.