Jump to content

java.lang.illegalStateException: zip file closed


zooid
 Share

This topic is 4300 days old. Please don't post here. Open a new topic instead.

Recommended Posts

  • Newbies

Hi

I have the same error: "java.lang.illegalStateException: zip file closed"

in certain environments, using ScriptMaster

Under Mac OS 10.4.11, Filemaker 10.0v3 runs fine with ScriptMaster

BUT

under OS 10.5.8, neither Filemaker 10.0v3 NOR 11.0.3 runs fine with ScriptMaster

without the error: "java.lang.illegalStateException: zip file closed"

- and yet Filemaker 8.5 runs it without the error

Could you advise?

Thank you!

:R)

Richard Philpott

Where are you getting this error? Can you post your plugin log?

FileMaker Client

OS X

/Users/userName/Library/Logs/360Plugin Logs/

/Users/userName/Library/Logs/360Plugin Logs/360Works FM WPE

/Users/userName/Library/Logs/360Plugin Logs/360Works FM Pro

Windows

DriveLetter:\Documents and Settings\<userName>\My Documents\360Plugin Logs\

DriveLetter:\Documents and Settings\All Users\Documents\360Works FM Pro

DriveLetter:\Documents and Settings\All Users\Documents\360Works FM WPE

Vista: DriveLetter:\Users\<userName>\Documents\360Plugin Logs\

  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...
  • Newbies

Hello,

same problem with me about "360Works ScriptMaster version 4.123"

same error: "java.lang.illegalStateException: zip file closed"

no error with a macBookPro OSX 10.6, FMP 8.5v2 or 9 or 11

error with MacBook, OSX 10.4.11, FMP 8.5v2, 360Works ScriptMaster version 4.123, java 1.5.0_19 (updated with release 10)

if somebody knows...

Many thanks

Frank

Link to comment
Share on other sites

  • Newbies

What is giving you these errors? Are you running a particular module?

This i the 3rd solution to register a script from "360 works scriptMaster"...

I copy two functions from ScriptMaster : "choose folder" and "select file"

I paste it into may Filemaker solution startup script

When I start, here is the error (java.lang.illegal...zip file closed)

(see attachment "open.jpg" a view of my startup script)

the complete first one is :

RegisterGroovy( "SelectFile" ; "import java.awt.*;¶

import javax.swing.JOptionPane;¶

¶

String title = \"Example File Chooser\";¶

FileDialog dialog = new FileDialog(JOptionPane.getRootFrame(),title);¶

dialog.show();¶

if (dialog.getFile() != null) {¶

return dialog.getDirectory() + dialog.getFile();¶

} else {¶

return 0;¶

}" )

the second :

RegisterGroovy( "ChooseFolder( startingPath ; prompt )" ; "import javax.swing.JFileChooser;¶

¶

JFileChooser chooser = new JFileChooser();¶

chooser.setFileSelectionMode( JFileChooser.DIRECTORIES_ONLY );¶

//You can switch this to JFileChooser.FILES_ONLY or JFileChooser.FILES_AND_DIRECTORIES if you want the user to be able to pick files¶

¶

if( startingPath != null ) chooser.setCurrentDirectory( new File(startingPath) );¶

if( prompt != null ) chooser.setDialogTitle( prompt );¶

¶

if( chooser.showOpenDialog( null ) == JFileChooser.APPROVE_OPTION ) {¶

return chooser.getSelectedFile().getAbsolutePath();¶

} else return \"\";" )

open.jpg

Link to comment
Share on other sites

Is there a possibility of taking this seriously please.

Not a single function is registering on startup making every file I use everyday suboptimal or just plain broken on this machine

Will gladly let you screen share.

Link to comment
Share on other sites

John,

I assure you that I am taking this seriously. Nobody had posted where they were getting the error or what they were doing to get the error until franfleis, and his post was late friday, after I was gone for the weekend already. I'm back in the office now, and I have his post to look at for trying to reproduce this issue.

Link to comment
Share on other sites

We're working on a fix for this issue. In the mean time, you can roll back to http://com.prosc.store.downloads.s3.amazonaws.com/360Works%20ScriptMaster-4_121.zip if you need the functionality immediately.

This plugin version is from before the auto-update fix, so if you distribute it through auto-update you will need to manually remove it or use our plugin remover at http://360works.com/remove-plugins before it can be updated through auto-update again.

Link to comment
Share on other sites

  • 3 weeks later...

This topic is 4300 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.