Jump to content

Some Questions about Instant Web Publishing


Peter Payne
 Share

This topic is 4319 days old. Please don't post here. Open a new topic instead.

Recommended Posts

Sorry for the noob questions, but I can't seem to find any proper answers. I am running Filemaker Server Advanced 9 and want to share certain databases with my San Diego office so they can access data. I turned on the server and all looks well, but when I view my server's IP address I only see the Apache default page. From within my own network, what URL should I be using to bring up my databases in a web interface or testing purposes? Something similar to [my server's local IP]:16000 but different since that's for the admin.

Link to comment
Share on other sites

Playing with this some more. Pretty sure the problem is because I have a normal disk that is the boot drive for my server (and backup disk), plus a fast 10,000 RPM drive that my databases are actually hosted on. I think I need to edit the http.conf so that it knows to look on the 2nd disk (Filemaker Main) rather than the default

I notice the http.conf has includes at the bottom for FMI/IWP, which look like this:

Include /private/etc/apache2/other/*.conf

#FMI_Configuration_V1

Include '/Library/FileMaker Server/Admin/admin-helper/WEB-INF/conf/fmi-test.conf'

Volumes/Server\ Main/Library/FileMaker\ Server/Admin/admin-helper/WEB-INF/conf/managerconfig.xml

#FMI_Configuration_V1

Include '/Library/FileMaker Server/Admin/admin-helper/WEB-INF/conf/fm-server-status.conf'

#FMI_Configuration_V1

Include '/Library/FileMaker Server/Admin/admin-helper/WEB-INF/conf/mod_jk.conf'

#FMI_Configuration_V1

Include '/Library/FileMaker Server/Web Publishing/publishing-engine/php/apache-2.2/httpd.conf.php'

I tried editing them to look like this (below) which would be (?) the path of the same directory on my alternate hard drive, hoping it would work (it was a nice try though). I stopped and restarted both IWP and web sharing in Mac OS X but it was no-go, it only broke all web serving and didn't show my databases.

Include /private/etc/apache2/other/*.conf

#FMI_Configuration_V1

Include 'Volumes/Server\ Main/Library/FileMaker Server/Admin/admin-helper/WEB-INF/conf/fmi-test.conf'

#Volumes/Server\ Main/Library/FileMaker\ Server/Admin/admin-helper/WEB-INF/conf/managerconfig.xml

#FMI_Configuration_V1

Include 'Volumes/Server\ Main/Library/FileMaker Server/Admin/admin-helper/WEB-INF/conf/fm-server-status.conf'

#FMI_Configuration_V1

Include 'Volumes/Server\ Main/Library/FileMaker Server/Admin/admin-helper/WEB-INF/conf/mod_jk.conf'

#FMI_Configuration_V1

Include 'Volumes/Server\ Main/Library/FileMaker Server/Web Publishing/publishing-engine/php/apache-2.2/httpd.conf.php'

So my question is, I guess, how do I store my databases on a 2nd disk and use IWP, manually "pointing" Apache to my database files, if that's what I need to do?

Link to comment
Share on other sites

Sorry for the noob questions, but I can't seem to find any proper answers. I am running Filemaker Server Advanced 9 and want to share certain databases with my San Diego office so they can access data. I turned on the server and all looks well, but when I view my server's IP address I only see the Apache default page. From within my own network, what URL should I be using to bring up my databases in a web interface or testing purposes? Something similar to [my server's local IP]:16000 but different since that's for the admin.

Assume that the IP address of the server is 192.0.0.2. Then the proper syntax for IWP is http://192.0.0.2/fmi/iwp.

Be sure that the fmiwp bit is checked in the Extended Privileges area of the FileMaker Pro file for the Privilege Set tied to the Account needed to open the file.

HTH

Steven

Link to comment
Share on other sites

Fah, one more question. I am having the devil's time figuring how I create user accounts for my staff to log in, set passwords and what not. Do I need to do it in terminal or use Netinfo manager or something? I know it's a server product and not "easy to use" or anything, but I'm amazed anything could be this hard to figure out, or documented in such a way that no person can figure it out without years of training. (Running 10.5.x on the server) Do I need to do some voodoo with Directory Utility or something?

Link to comment
Share on other sites

Have you looked at FileMaker > Help > Product Documentation > Instant Web Publishing Guide?

IWP uses accounts/passwords that you set up in the file using FileMaker Pro: File > Manage > Security (or you could use a script in IWP that uses the Add Account script step). Be sure the account privileges include IWP, it's a checkbox under Extended Privileges.

Link to comment
Share on other sites

Fah, one more question. I am having the devil's time figuring how I create user accounts for my staff to log in, set passwords and what not. Do I need to do it in terminal or use Netinfo manager or something? I know it's a server product and not "easy to use" or anything, but I'm amazed anything could be this hard to figure out, or documented in such a way that no person can figure it out without years of training. (Running 10.5.x on the server) Do I need to do some voodoo with Directory Utility or something?

What Tom Fitch said. It's actually straightforward. Accounts can be internal to the file, in local Groups on the server, or part of an Open Directory or Active Directory domain. There is quite a bit of good information put on this including Wim Decorte's excellent server videos found here, my Security videos, although they are older versions, found here, as well as various White Papers.

HTH

Steven

Link to comment
Share on other sites

Thanks for the info.

Now I've done one final stupid thing. I set up everything and it worked fine. I made accounts that could access the IWP no problem, and in the process seem to have set some reqirement that the admin password be entered when the databases were loaded. But when my staff came in (before I got here) they were not sure what was happening and restarted the server (normally through the terminal). When it rebooted, all databases were invisible to client software, which has never happened to me in 15 years of running FM. Here's a screenshot. The 192.168.1.11 server should show databases, but there's nothing. Logging in through the admin, everything is opened and running normally, with the only changes being that I added IWP access accounts and set an admin password for some databases. I am still googling to see why this could be, but does anyone know what would cause my databases to become invisible like this?

Link to comment
Share on other sites

First thing I would do would be to revert to a backup before the changes were made, and see if the files appear again. If not, then the issue has nothing to do with the new account and it might be something else.

Link to comment
Share on other sites

First thing I would do would be to revert to a backup before the changes were made, and see if the files appear again. If not, then the issue has nothing to do with the new account and it might be something else.

Good suggestion. I went back to a backup from two days ago and restored from that, fixing the permissions again. But...no go. The files are still seemingly running fine, according to the terminal logs and admin, but I cannot "see" them from a Filemaker client. So it seems to be unrelated to the internal IWP accounts and passwords I set up for the databases I wanted to share on IWP, and more to something else. Yet I didn't do anything else, other than install a no-up.com DUC updater for updating DNS, that shouldn't cause these problems.

Any other suggestions? It's like Filemaker Server has been set to hide the open databases unless a user is already logged in ad an admin or something, but there's no way to log in to something you can't see.

I am turning on "Allow members of the 'fmsadmin' group to login' in case that changes anything, but what does this mean? Is it something about Mac OS accounts (unix accounts) or something within Filemaker?

Link to comment
Share on other sites

I'd start looking between the server and the client for blocks: routers, firewalls, etc. Something has changed. Has the config of FMS changed?

Link to comment
Share on other sites

I'd start looking between the server and the client for blocks: routers, firewalls, etc. Something has changed. Has the config of FMS changed?

Thanks, I'll try this tonight when we're done working. If nothing else I'll try reinstalling the server software. Config of FMS didn't change other than to set up IWP. Router (running Mac OS X) is set to allow all incoming connections. Router is the same but I'll try rewiring it tonight.

Link to comment
Share on other sites

Hi, I am pretty sure the 360Works and AdminAnywhere plugins I'd stupidly installed (and forgot about) caused the problem. Removing them didn't fix anything, so I reinstalled everything and it's all running well, thanks for everyone's ehlp.

Now one other small question. When I did my install (of Filemaker Server 9 Advanced) it asked me if I wanted to install the IWP component, and I clicked no, thinking I would set it up later. Now it seems that IWP can't be used, as it's deactivated, and I see "an error occurred when communicating with the server." (Yes I have Web Sharing turned on on the Mac that's my server). Is there anything to do to make IWP come back or shall I re-install it again? Also, is there any fundamental issue with installing over the existing reinstall? I have a complex backup system, saving copies of my databases three times a day over a week and I do...not...want to sit there and recreate those backups again, having just done it.

Link to comment
Share on other sites

This topic is 4319 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.