Jump to content

Date problems


Wallis
 Share

This topic is 4312 days old. Please don't post here. Open a new topic instead.

Recommended Posts

  • Newbies

I'm fairly new to Filemaker.

I'm trying to add a Drop Down Calendar. I set up a date field and then formatted it as a Drop Down Calendar. When I see it on the form, it looks good so far - I click on it and see the month and can select a dat. But then the problems start...

I get a beep and a warning message "The value of tis field must be a valid date in the range of years 1 to 4000 and should look like "25/12/2003".

Now the date shows as 25 12 2003, so I go to Edit Layout, Select Date Format and select the layout that gives 25/12/2003. But the next date I try to select, it resets to 25 12 2003, beeps and I get the same error message.I then have to Revert Field.

This is driving me crazy! Any help would be much appreciated.

Walt

Link to comment
Share on other sites

  • Newbies

Can you replicate this problem in a brand new file? If yes, what happens if you click into a date field (with no calendar attached) and select Insert > Current Date?

Yes,I can replicate it. I set up a new Database with a single Field - "Date". I set that to type: Date.

I then added a drop down calendar and selected a date - I got the same Error message. I changed the drop down calendar to Edit box and did "Insert Current date" - still the same error message

So I changed the field to type: Timestamp (you never know!) - but nothing changed, except that the error message now includes a time as well as a date format

Walt

Link to comment
Share on other sites

Check your computer OS setting for 'short date' format. Make sure it includes separators between the items (preferably slashes, but hyphens or dots should work just as well).

Note that the way you format the field on the layout is irrelevant here: you could format it to display as "2011x04x17" but Filemaker would not let you enter a date this way unless your OS short date was set to 'yyyyxmmxdd'.

Link to comment
Share on other sites

  • Newbies

Check your computer OS setting for 'short date' format. Make sure it includes separators between the items (preferably slashes, but hyphens or dots should work just as well).

Note that the way you format the field on the layout is irrelevant here: you could format it to display as "2011x04x17" but Filemaker would not let you enter a date this way unless your OS short date was set to 'yyyyxmmxdd'.

Thanks so much for your help - that solved it - Phew!

Walt

Link to comment
Share on other sites

This topic is 4312 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.