Jump to content

Webdirect pauses when loading Startup script


Dan N
 Share

This topic is 2419 days old. Please don't post here. Open a new topic instead.

Recommended Posts

Webdirect inside a Joomla iframe gets 'stuck' (see attachment) displaying the status and menu bar.  It doesn't always happen, sometimes the script completes as it should.  When it doesn't, it requires clicking within the iframe to conclude remaining script steps.  Below are a few things I have already tried.

 

Moving the script steps for hiding status and menu.

Removing the script steps for hiding status and menu.

Using http: in place of https: in URL.

Same results when loading URL directly with no iframe.

 

Same behavior in IE11, Chrome35 in Win7 as well as Safari and Chrome in OSx Mavericks so I don't believe it is a browser issue.

 

Seems to happen more often if the browser is refreshed.  If the URL is loaded in a 'virgin' session, it seems to be fine, simply flashing the status bar before loading the appropriate layout.

 

Does anyone have any suggestions for solving this issue?  This is a game stopper for my project as I cannot expect the client click in the iframe when this randomly happens.

 

Thanks in advance for your help.

 

Dan Noble

 

post-92362-0-20632100-1402088669_thumb.p

Link to comment
Share on other sites

  • 6 months later...

This topic is 2419 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Similar Content

    • By innodat
      Does anyone know how to fix an image from appearing too small within a container in WebDirect? In FMP it fills the container. Tried to "play" with most settings relating to containers, including margins, frame, etc. - no success. The problem presents itself in Safari in macOS Catalina, as well as Edge on Windows 10

      See image attached.
      I sure hope this isn't a bug! Because if it's a bug then it will get fixed... well, never. 
       

    • By steveald
      I would like to use the OnLayoutSizeChange script trigger to control how my WebDirect app window appears on various devices. But I can't find any script steps that are compatible with WebDirect that I can use to make this happen. I had hoped it was as simple as something like If Get(Device) = 4 (iPhone) then Set Zoom Level [50%]. Am I limited to having the script trigger go to different layouts created at different sizes? I would rather not have to duplicate all of the details of the app's layouts for multiple device scenarios.
    • By stan111
      Gents,
      two problems:
      1. I can't access my db file using FilemakerGo. Localhost works, Webdirect - doesn't. 
      2. I can't either access my file via mobile browsers. PC browsers work, mobile - doesn't. Tested on my iPhone with Safari and Chrome.
      Thanks for help.

    • By jaboda
      Hi,
      This is a peculiar bug which seems to have appeared with a recent Chrome update.
      Create a Web Viewer control with the following content:
      "data:text/html,<html><body bgcolor=\"#EEEEEE\">HELLO</body></html>" Then view the layout in WebDirect in Chrome. You'll notice it doesn't display anything. Remove the bgcolor and it works as expected. It also works in FileMaker.
      There are numerous workarounds but I can't find out how to fix it.
       
      Anyone else experienced this?
    • By Stickybeak
      I am investigating moving my database to web direct. To do so I need to get scribe working on fmphost.
      I have added a script step to register the plugin - which works fine in self hosted or fmphosted but I still get an error telling me that I need to install the plugin when I try to run it in webdirect.
       
      I have be speaking with fmphost who reported "It turns out the Scribe plugin also needed to be enabled in the FileMaker Server Admin Console. We have enabled the plugin, so it should be working now.".
      I am wondering if my license wont work with web direct. My license is described as "360Works Scribe 2.15 / Upgrade from Single User License to Scribe Workgroup License (Upgrade)".
      Any ideas?
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.