Sign in to follow this  
Followers 0
smower

FileMaker Web Viewer How do I disable JavaScript Security Message?

5 posts in this topic

Hello FileMaker Group,

I wrote a little javascript to run a FileMaker script from the web viewer and use a data url in the web viewer to run it. Unfortunately, every time I run it, I get a warning message box that says "An ActiveX control on this page might be unsafe to interact with other parts of the page. Do you want to allow this interaction." Does anybody know any way to prevent that message from coming up every single time?

Create a a webviewer and a field called "html" and put this javascript code in the field:

In the webviewer define the url calculation as follows:

"data:text/html," & html

Here is the javascript that goes into the html field.

var FMApp;

var FMDocs;

var FMActiveDoc;

var myOpenFile;

FMApp = new ActiveXObject("FMPRO.Application")

FMDocs = FMApp.Documents;

FMActiveDoc = FMDocs.Active;

FMActiveDoc.DoFMScript ("testscript")

FMApp = null

FMDocs = null

FMActiveDoc = null

myOpenFile = null;

Thanks in advance!

Shawn

Share this post


Link to post
Share on other sites

This is in my humble opinion not a filemaker matter, but merely what security level is implemented in your organization:

http://technet.microsoft.com/en-us/library/bb457006.aspx

--sd

Share this post


Link to post
Share on other sites

Thanks for responding. This is happening on my local desktop computer in my house. Do you know specifically how I could get it to allow that script to run locally? I have played with a few settings but to no avail.

Share this post


Link to post
Share on other sites

No it's a operating system I only deal with if I really have to, such as lay outing for clients with this inclination. However might you get away with it turning Firefox your default browser.

--sd

Share this post


Link to post
Share on other sites

Unfortunately, the browser is an embedded windows control. So chasing the system default browser, won't resolve this.

Try adjusting your IE settings. WebViewer should 'inherit' its settings from those made in internet explorer:

Tools>>Internet Options...

Security Tab

Local Intranet - Cutom Level...

ActiveX controls and plug-ins

Automatic prompting for ActiveX controls (Enable)

Binary and script behaviours (Enable)

Download signed ActiveX controls (Enable)

Download unsigned ActiveX controls (Enable)

Initialize and script ActiveX controls not marked as safe (Enable)

RUN ActiveX controls and plug-ins (Enable)

Script ActiveX controls marked safe for scripting (Enable)

Are you trying to pass data back from the javascript which is running in a webviewer, to Filemaker? I have figured out how to do this with the clipboard, and recently, figured out how to do it *without* the clipboard.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0