Jump to content
Sign in to follow this  
Hijack

System level scripts run identity

Recommended Posts

I have a couple of sequence scripts configured on our FM14 server (under Windows 2008 R2) and for some reason, the system level scripts after the internal FM scripts no longer launch under the identity I specify in the schedule config.  They always launch under System and that's causing access problems.  The server has been rebooted and I have tried brand new schedules for the tasks but nothing changes.  Anyone seen similar behavior and have a solution?

Thanks

Share this post


Link to post
Share on other sites

What was changed on the server?  FMS patch?  OS patch?

What is the account used, an AD account?  Local OS account?

Is FMS set up to run as local system or with a customized account?

Share this post


Link to post
Share on other sites

FM Service is running under local system.  ID to run the system script under is a domain account.  Server had been up for 84 days prior to today's reboot so nothing has changed since it was last working.

Share this post


Link to post
Share on other sites

Unfortunately I had to convert the FMS service to run under a domain admin account to get it to run scheduled tasks with the access I need.  It's disappointing that these strange bugs pop up with FM frequently and have no known solution.

Share this post


Link to post
Share on other sites
2 hours ago, Hijack said:

 It's disappointing that these strange bugs pop up with FM frequently and have no known solution.

 

It's a big jump to declare something a bug with no know solution.  99% of the time it comes down to how the feature is used...  AFAIK there are no know bugs around what you are describing.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By Richard Fincher
      My production Filemaker Server 14 running on Mac OS X 10.11 El Capitan (Not Mac OS X Server) has been running fine for a year since I last installed the Thawte SSL Certificate.  After renewing the certifate this year, I've tried various different methods of importing the new certificate, which came with an intermediate certificate, but I can't seem to get the intermediate certificate installed.  I've been mostly using something like:
      sudo fmsadmin certificate import --keyfile /Users/richardfincher/Desktop/GBROOMX36-4X/private.key /Users/richardfincher//Desktop/GBROOMX36-4X/ssl_certificate.crt
       
      I've also tried importing it through the web control panel.  It was necessary to remove the old private key thus.:
      sudo rm /Library/FileMaker\ Server/CStore/serverKey.pem
      After it is (apparently) installed, I usually restart with :
      sudo fmsadmin restart adminserver
      although a few times I have rebooted the server (not a VM)
       
      Any thoughts welcome....
       
      Oh, one thing is, a year ago it might have been still on Mac OS X 10.8.5 Mountain Lion, which was the previous OS before I upgraded it.
    • By Qam Qam
      hello every one 
      there is a way to send SMS without any plugins , 
      there is a teacher named (guy setvens) who have course on udemy to explain it , problem is its paid , i i cant afford it 
      any one knows how to do it 
      please 
      i have bought 10000 SMS with api form sms provider 
      but i dont know how to use it without plugins 
       
    • By Qam Qam
      Hello every one 
      i want to mention multiple filed in the email 
      like agent name 
      created by 
      and date of creation 
      to be sent to the manger 
      now i can only send one field  in the email 




    • By Qam Qam
      Hello everyone ,
      this is my 1st post in this helpful website 
      thank you guys ive learned a lot 
       
      iam working on recruiting software for my office 
      its simple 
      my issue now that i want to set simple days count down timer 
      for example if my client requested his procedure finish in 60 days or 90 days 
      i want to know left days in a list so i can give pioirty 
      so i used the following 
      GetAsNumber ( Contract_End_Date - Get ( CurrentDate ) )      
      which appears in the remaining days filed 
      it worked fine for me 
      the issue is 
      it remains  frozen , next day its the same value like yesterday 
       
      sorry for my bad English '
       
      please help me 
      thank you 

    • By DR. ALI BAHAR
      Dear All,
      I have tried to access the SQL database, through the ODBC, as a data source in the online filemaker solution but I am not successful , i don't know if i am missing something ?
      can any one help in this regard ?
      Thanks in advance.
      Regards
      Mr. Ali Bahar
      Pakistan.
×

Important Information

By using this site, you agree to our Terms of Use.