Jump to content

Office 365 SMTP Connection Fails

Recommended Posts

CICT    0
Posted (edited)

We're assessing the demo version of the Email plug-in 3.02 with Filemaker Pro Advanced v16 as a potential replacement for our existing plug-in.

We're unable to connect to the smtp.office365.com server using port 587 and TLS. The documentation is light on detail, particularly the secureConnection and forceTrust parameters (or arguments?) as there is no reference to them at all within the text. I've found a posting on forceTrust here, but no information on secureConnection. We've tried every combination we can think within the parameters and arguments, but have had no success. There is one or two postings here relating to Office 365 and SMTP, but the detail was either never added or has been removed.

We've finally resorted to entering the following into 360Works Email Plugin Examples_16+ file:

SMTP Host: smtp.office365.com:587, SMTP User and Password (which are correct), StartTLS selected, Force Trust SSL selected

This final test was carried out on a Mac, the intention is to use this within Windows, and the attached file is the Mac log file, which should only list a single attempt to make a secure connection to the server. Note, the actual user name within the log file has been replaced by username@domain.com.

Our Outlook365 account is using our own domain, hence user names are based around this.

We'd appreciate your earliest response, as this won't be an option to us unless it is compatible with Office 365 SMTP or are we just missing something very obvious?

Many thanks



SMTP Connect.log

Edited by CICT

Share this post

Link to post
Share on other sites
3Feathers    0

+1 to above - we are in exactly the same scenario trying the exact same thing.

A resolution here would be very welcomed.

Share this post

Link to post
Share on other sites
ryan360Works    18


We have resolved Andy's issue via our support system. Please download version 3.05 from our website (pushed yesterday) and retest. If you continue to have issues, please email support@360works.com . 

Share this post

Link to post
Share on other sites
ryan360Works    18

Apologies, I believe it was a different Andrew with the same issue. Please download 3.05 of the email plugin and try again. Pass in "true" for the secure connection parameter.

Share this post

Link to post
Share on other sites
CICT    0

To confirm that Ryan and his team have resolved our Office 365 problems with the latest version.



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Who Viewed the Topic

    14 members have viewed this topic:
    Ron Cates  MikeKD  melmitts707  doughemi  comment  Lee Smith  jjjjp  Blaze  _ian  LaRetta  BruceR  Aussie John  Wim Decorte  Steve Martino 
  • Similar Content

    • By Gary Hoffman
      We have been using 360Works Email Plugin for several years to great success. The grad school recruiting team sends messages to admitted students that include both standard and custom-created PDF letters as attachments. The email script runs in the FMP client machine and we are using a special SMTP server address alias reserved for automated mail messages from on campus devices. This has worked well from both wired and wireless clients until the campus network managers started using NAT-addresses for wifi clients. Now we discover that a machine on the wifi network cannot reach the designated SMTP server address, but the Email Plugin error message says that the email addresses are invalid, rather than complaining about not connecting to the SMTP server. We can get the connection failure message by changing the EmailConnectSMTP entry to a bad address.
      Fortunately, we have other SMTP servers to use which will work with wifi users. But we chased the wrong error for so long, I thought I should report this.
    • By Oyseka
      Hi All,
      Having been shown the bug in 10.11.6 and FMP by bcooney I am setting up the Send Mail script to send via SMTP. This works OK in the Invoice table but I can not get it to work in the Quotes table. There does not appear to be anything in the mail setup script that is capable of creating the error and I have tried three different smtp server addresses with the same result. I have used all three smtp server addresses on the Invoice table as well and they all work. Can anyone assist please.

    • By Simon UK
      Probably a junior error so apologies in advance but I cannot get my clients DB to connect to their Office 365 SMTP relay.
      Hostname: smtp.office365.com:587
      Username = username
      Password = password
      Username and password are those for the login to Outlook Office 365, I assumed these would be correct?
      But I'm getting "authentication failed, please check authentication info"
      Log attached, any ideas????
      Best regards and thank you,
      UPDATE: This has now been resolved however I'm getting an error 'Exception Reading Response' ...
    • By Brian S
      On EmailConnectSMTP for both Gmail and iCloud, I get this error when trying to use TLS. Is my syntax wrong, or is there a bigger issue here?
      EmailConnectSMTP( "smtp.mail.me.com:587" ; "XXX@me.com" ; "XXX" ; "tls=true" ; "timeout=10" )
    • By thebridge
      There is another thread on this topic from September 2015 . Thought I would give the problem/solution its on thread to easily help others. this had me baffled and scratching my head as everything seemed fine in the script....
      then Don Bahash wrote:
      "OMG ... I just got it to work!  So, for me, the solution was to remove all the references to field "id_constant" in the SMTP dialog box in script "0783 Send Email by Parameter"
      So following Don's solution ... I hard coded each of the smtp fields that referenced the prefs table and it solved the problem.
      I then went back in and undid each change one at a time and tested. I saved the password field for last because I suspected that was the problem child.
      Bingo..,. it is the culprit...
      after careful review of the displayed fields on the email tab in Preferences, I realized that the password field was actually the password display field. once I changed that to the password field and entered in the password ... problem solved! 4.5v2 now sends emails via smtp in the Contacts module

      hope this helps others!
      Robert Bloomfield

Important Information

By using this site, you agree to our Terms of Use.