Jump to content
Sign in to follow this  
mbarrett65

fmp17 Problem with Citrix and "change cursor to hand"

Recommended Posts

I am using Citrix to access my FM17 solution. Recently, I noticed that the cursor gets jerky/won't move smoothly over a button that has "change cursor to hand over button" selected. It seems like maybe it's making a call back to the server. If I disable "change cursor to hand" it becomes smooth again. This does not happen when using the client software. I believe this started happening within a month or so; we've been using Citrix for years and don't think this has been an issue. Thanks for any insights. 

Share this post


Link to post
Share on other sites

Does the button have a calculated tooltip maybe?

Share this post


Link to post
Share on other sites

Thanks for your response. The buttons do not have a calculated tooltip, but they do have tool tips and removing that seems to have helped the issue.

I did discover that it only seems to happen when my Mac laptop is connected to another monitor. When I unplug the monitor, the jerkiness goes away on the laptop screen. 

Edited by mbarrett65

Share this post


Link to post
Share on other sites

Hmmm, could be something to do with screen resolution?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By flutegirl
      To try to explain the setup as succinctly as possible:
      Database is running on a FM17 Server (on a Windows virtual(?) machine... Our IT department handles that part).
      The FM database does a number of imports every morning from our primary (4D) database, using an ODBC driver, but I have not found a way to have those imports run successfully from the server, so I have them running on an instance on a secondary user account on my desktop computer.
      The scripts are triggered by adding a record to a table, which is checked every five minutes using an OnTimer script.  I run a separate instance of FM17 on my user account so that I can use the database even if there is an import running.
      This solution has been working (fairly) well for a number of years, but last week, my desktop computer was updated to Mojave (10.14.6), and since that upgrade, it seems that the imports on the secondary account will only run while that user account is active.
      1) Is anyone else doing anything similar, where they have an instance of FM running on a separate user account?
      2) If so, have you had any trouble with Mojave, or have suggestions on what may be going on?
      3) Any suggestions on how to fix this?  My initial thought is to just open the database using FMP on the Server system and try having the imports run from there, but am concerned that might also have problems.
      Any suggestions would be greatly appreciated.
       
    • By OneStop
      I have a field called Price. I need to create another field called calculated price that will add a percentage depending on the value of the original Price field.
       
      Example:
      If the Price is $100.00 or more Subtract 10% from the price
      If the price is $10.00 or less Subtract .25%
      If the Price is between $10 and $50.00 Subtract .5%
      If the Price is between $50 and %100.00 Subtract .75%
       
      and so on and so on...
      So if I have a record with a Price of $1.00 the calculation will fill in the Calculated Price field with $.75
    • By BAleiHi
      I have a layout calculation that looks like:
      Round(If($$NoGPABump = 1;Classes::GPANoBump; Classes::GPABumped);2)
      In most instances, this rounds the appropriate value to 2 decimals  and displays those two digits.  But on occasion, it displays only one decimal as in this one:
      .  Instead I want to see 4.20.  If I round to, say, 4 decimals, it works properly: .  Rounding to 3 digits gives 4.199.  How do I get the trailing zero to show up?  This seems to be consistent for all data that rounds to a last digit of zero.  Is this a bug?  Is there a workaround?  Thanks,
       
    • By vinnygi
      I have a layout with a number of button bars, all with the same style. Each button is set to have an inner shadow and a white fill on Hover. For any of the buttons that call a popover, after the popover is closed, the hover shadow no longer works, but the fill still changes to white.  I've tried adding a refresh object script trigger when closing the popover, but that doesn't work.
      Some of the buttons are currently placeholders, which just call a script that exits itself so I can test the hover state.  Those work fine.
    • By Will_Logic
      Hi, I am using the Base Elements plugin Execute SQL command to select SQL on a table in another FileMaker file. For a file with many fields and quite a lot data in some fields, this times as about 1 minute just for SQL SELECT command for 1,000 rows. I haven't used MBS (monkeybread software) plugin yet, but I wonder if anyone knows if it is significantly faster?
      I.e. BE_FileMakerSQL vs. MBS(FM.SQL.Execute..) - is one significantly faster?
      Here's the code to select 1,000 rows for reference, $timer_seconds comes as about 60 seconds here. If I export same table internally in FileMaker using the menu export to Excel, it takes 29 minutes for all 41,000 rows, so timing seems similar for the Base Elements SQL. (NB there is some flag going on here in the FileMaker database so internal export gets 41,000 rows but script SQL SELECT COUNT(*) gets 200,000 rows for same table, but I don't think that is relevant to my question).
       
      Set Variable [$time1; Value: Get(CurrentTimeUTCMilliseconds)] Set Variable [$part_ca; Value: BE_FileMakerSQL ( "SELECT * FROM Contact_ACTIVITY OFFSET 100000 ROWS FETCH FIRST 1000 ROWS ONLY" ; "&≠≠&" ; "EOR≠≠EOR" ; "DataContacts11" )] Set Variable [$timer_seconds; Value: (Get(CurrentTimeUTCMilliseconds) - $time1) / 1000] MBS command I think would be something like:
      MBS( "FM.SQL.Execute"; "DataContacts11"; "SELECT * FROM Contact_ACTIVITY OFFSET 100000 ROWS FETCH FIRST 1000 ROWS ONLY" ; ...delimiters here I'm assuming.. ) We only have base FileMaker here on machine I am using, which can run the Base Elements plugin, but to run MBS plugin, needs FileMaker Pro Advanced to install it I think, am getting several databases in roughly same FM format where script workspace disabled, hence need to use SQL select run from script in my own external FileMaker file. Might consider getting FMP Pro Advanced if MBS is faster.
      Tx any suggestions!
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.