Jump to content

Recommended Posts

Just installed Filemaker Server 19. The DB files are all closed. Only the sampler DB is open.

My DB files are coming from Version 16 and they are all .fmp12

Link to post
Share on other sites
  • Replies 12
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

I did.  Just installed two of them in the last few days. See my last post.  In both scenarios: - client had downloaded the license cert the day that FM 19 was released but that only works un

The event log will tell you why FMS doesn't want to open them.

Very likely it will be because FMS deems them to be not secure (accounts with no passwords, some guest access restrictions,...).  You can either fix your files or tell FMS to operate in a less secure fashion by changing a setting from the command line.

Link to post
Share on other sites

fmsadmin set serverprefs RequireSecureDB=false

But think twice before using it; there is a very good reason why that setting is on by default... it is a strong signal that you really should beef up the security for your files.

Link to post
Share on other sites
  • Newbies

Hi,

I too have a problem opening files in FMS 19. In my case, not even the sample file will open. I have tried so many things and it still doesn't work. I tried encrypting the file before upload, setting a password, and adding extended privileges.

After that, I tried running sudo dseditgroup -o edit -a <username> -t user fmsadmin (where username was what is returned from whoami).

Nothing has worked. When I try to open the file it asks for the encryption password but then just hangs in "opening" state with a small red circle with a minus sign inside. I have tried exactly the same with multiple files and the result is the same. I have even unistalled and reinstalled FMS and FMP.

I have looked around for guidance and solutions online but find myself running out of things to try.

The last thing I try was the suggestion above:

fmsadmin set serverprefs RequireSecureDB=false

..but, that has not worked either.

Please, anybody who can help me solve this problem. I don't know what to do!

Thank you!

 

 

 

Link to post
Share on other sites

There was an issue with the license certificates around June 1st.  So go to the Electronic Download page in the email you got from Claris when you bought your license or the last renewal email and download a new license cert and import it through the admin console.

(Note that we are NOT talking about an SSL certificate here).

If you can't get the new license cert quickly and you need to have your files up and running ASAP then set the clock on the server to date somewhere in May and your files will open.

Link to post
Share on other sites

Same here. FMS doesn't list the files using fmsadmin, not even the sample file, but it shows it in the web driven admin console. When trying to open a file, no log entry is generated in the event.log. No error. No nothing. The fact that the web admin console shows the files, and the fmsadmin command doesn't, is a clear indication that something is completely off.

fmsadmin set serverprefs RequireSecureDB=false

is not supposed to be necessary when you first start up FMS. As I wrote above, even the sample file does not open. It seems a bit strange to me that FMS19 would not even open up the unencrypted sample file without entering some obscure command line instruction. Of course Wim's remark was towards the OP, and quite correct, allthough it seems like twisted logic to me to use the "secure" folder for your files and the serverprefs set to false.

Allthough it is not mentioned in this post, I'm pretty sure this is an issue on the macOS server. This morning I tried to upgrade my dev server, and stumbled upon the same issue that kymie is reporting. I went to the correct ritual: uninstalling FileMaker Server 18, and restarting afterwards ( the fmserver httpd processes are not stopped when uninstalling ).

Luckily this is a virtual machine, so I tried a few things, each time reverting the VM , but they all lead to the same problem.

  • I tried removing the "FileMaker Server" folder completely
  • I deleted the "fmadmin" group and the "fmserver" user after uninstall,  because not doing so leads to a macOS bug after FMS install ( the Finder info bug ). It solves the Finder info bug, but not the FMS problem.
  • I reverted the virtual machine to the "clean install" 10.15.4 snapshot, and upgraded it first to 10.15.5. I then installed FMS 19, so no upgrade, it doesn't get much more "plain vanilla" as this.
  • I tried running the VM without SIP
  • I tried installing FMS as root user instead of

Amazing. Reverting to FMS 18 on the dev server, which is running rather OK on Catalina 10.15.5. 

I wonder if there is anyone who got FMS19 running with files actually opened on Catalina. Please tell.

35 minutes ago, Wim Decorte said:

There was an issue with the license certificates around June 1st.  So go to the Electronic Download page in the email you got from Claris when you bought your license or the last renewal email and download a new license cert and import it through the admin console.

(Note that we are NOT talking about an SSL certificate here).

If you can't get the new license cert quickly and you need to have your files up and running ASAP then set the clock on the server to date somewhere in May and your files will open.

O goodie. So the license I'm using actually gives me the right to open 0 files?

Link to post
Share on other sites
1 minute ago, Peter Wagemans said:

I wonder if there is anyone who got FMS19 running with files actually opened on Catalina. Please tell.

I did.  Just installed two of them in the last few days.

See my last post.  In both scenarios:

- client had downloaded the license cert the day that FM 19 was released but that only works until June 1st.  Claris has since updated the license certs so you need to download a new one

- the trial cert also doesn't work so it is not as simple as installing the server in trial mode.  Perhaps if you download the "a" variant of the installer but I had the. one from when 19 was just released which is not that latest "a" version.

fms_19.0.1.103a vs fms_19.0.1.103

If you are stuck with old installer and cannot get trial working and don't have access to the new license cert then just set the clock back to before June 1st and you're good to go.

Obviously other things won't work like external authentication, or anything that relies on a security protocol that checks the date and time.

 

  • Thanks 1
Link to post
Share on other sites

Thanks Wim. I spent some time on my reply and missed your very helpful remark. I did install a fresh Catalina server with FMS 19 last week without any issues, I should have thought about this.

Link to post
Share on other sites

Support does not send out emails, the Marketing department does.

Support is active on the community forum community.claris.com where this issue has been discussed at length, plus they have a knowledge base article on it: https://support.claris.com/s/article/Installation-issues-with-FileMaker-Server-and-FileMaker-Cloud?language=en_US

The information is out there...

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.