Jump to content

Why are some fonts and all font/options grayed out?


Recommended Posts

I am using FMPro 16 on a Macintosh (MacOS 10.13)

In Browse mode, viewing Format>Font I see the following:

image.png.b41d0ca06c71b048c4812177fe07d3ed.png

PROBLEM:  some of the fonts installed on my Mac are grayed out, and ALL of the "options" (Roman, Book, etc) are grayed out.

In EVERY other programs on my Mac these fonts are available and work and print perfectly.

CAN SOMEBODY please explain what is the problem that FMPro has with them.

And if possible, tell me how I can fix this.       Thanks.

 

Link to post
Share on other sites

No.  I should have mentioned "while the cursor is in a field AND the text is selected".

I have just realized what the answer is:
in Browse mode, you cannot apply Format>Font     :)
You have to be in LAYOUT mode, and then all of the fonts are NOT grayed-out.

What was misdirecting me was :  
in Browse mode, SOME fonts ARE available, and others are not, but NONE will actually have any effect if applied!!!
I hadn't tried applying any of the not-grayed-out fonts in Browse mode, because none of the fonts I wanted were not-grayed-out!

SUMMARY:  some fonts seem to be available in Format>Font when in Browse mode but really they will do nothing!
Applying fonts only works when in Layout mode.

Link to post
Share on other sites
1 hour ago, philipcaplan said:

in Browse mode, you cannot apply Format>Font     :)
You have to be in LAYOUT mode

You are very much mistaken about that. In Browse mode, you CAN apply formats to selected text (provided the field is modifiable). This text then becomes formatted text. In Layout mode, you apply formatting  to a field (or a text object). The field then displays its contents in that formatting - unless the contents has been formatted otherwise.

 

Edited by comment
Link to post
Share on other sites

Thanks for correcting me, comment.

As always YOU ARE CORRECT   :)

The field I was trying to apply the formatting to was a Calculation field.

What really confused me was that in a situation where I was trying to apply the format to a non-modifiable field in Browse mode, FMPro was showing SOME FONTS grayed-out, and some NOT GRAYED-OUT.

Anyway, thank you again, problem solved.

Link to post
Share on other sites
1 hour ago, philipcaplan said:

FMPro was showing SOME FONTS grayed-out, and some NOT GRAYED-OUT

The fonts that are NOT greyed out are fonts that have variations and cannot be selected directly. Eventually ALL selectable options are greyed out.

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.