Jump to content

Recommended Posts

  • Newbies

We just started hosting our WebDirect solution on a Mac mini at MacStadium.com. (too many troubles with AWS and Windows servers) All was fine and dandy until we restarted the Mac. Now we cannot connect to FMS Console nor WebDirect - we use a fully qualified subdomain.  We reinstalled the SSL Certificate and have jumped through every hoop we can think of. We even did an uninstall and reinstall of FMS19

We are stuck and need to get this back up and running as quickly as possible. This is an all-hands-on-deck situation for us and we will appreciate any feedback you can provide.

Thanks,

Doug

Link to post
Share on other sites

A client of mine on Thursday had this issue where SSL would not work for admin console and would not work for any WPE but 5003 for FMP client access worked with green padlock.

We had to setup a new machine temporarily on Big Sir while the old machine is in quarantine the goal is to contact Claris tomorrow to see if they can learn anything why the WPE and SSL is going deaf and reinstallation didn't help. 

 

 

From the release Notes:

  • A new version of Java JRE or JDK is no longer required when enabling the Web Publishing Engine. If the JAVA_HOME system environmental variable is set, the Web Publishing Engine uses the existing version of Java and you're not prompted to download another version.
  • When FileMaker clients cancel finds in hosted files, finds are now halted quickly. Previously, canceled finds continued to run on the host and failed to stop promptly on clients.
  • FileMaker Server supports HTTP/2, which provides faster web performance for web publishing including Claris FileMaker WebDirect®, FileMaker Data API, and XML. HTTP/2 is enabled by default on all versions of Windows and Linux. HTTP/2 is available on macOS Catalina or higher but must be enabled with the Enable_HTTP2.sh script, which is located in /FileMaker Server/HTTPServer/.

    Note: HTTP/2 is not supported on earlier versions of macOS.

    If you’re using HTTP/2 on the Mac platform, be aware of the following:

    • Apache HTTP Server (httpd) processes may fail when using the FileMaker Data API.
    • PHP web publishing is not supported.
    • Use the default installation directory since custom locations are not supported.

 

Link to post
Share on other sites
  • Newbies

We got this reply from FileMaker Engineering team: Please use the command "fmsadmin start httpserver" on Terminal, it will fix the problem.

We ran it and it worked - how in the heck were we supposed to know this, where is this info published. We also got this tidbit of info:

It sounds like you are running into the issue described here:
 
This issue happens on macOS only, where httpd sometimes fails to start after rebooting the OS. Any time you reboot macOS, we recommend checking if httpd is running or not with this command:
ps -e | grep httpd
If httpd is running, then there should be multiple httpd processes listed. If it is not running, it can be started with the command provided. 

More unpublished information.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.