Jump to content

Filemaker Server 18, Mac OS Big Sur, LetsEncrypt, Certbot failure


This topic is 399 days old. Please don't post here. Open a new topic instead.

Recommended Posts

  • Newbies

I have been trying to update the default SSL cert for a while now.

I followed the steps in the great BlueFeather Certbot/LetsEncrypt integration guide.

When I run the GetSSL.sh script, it gets to installing the new cert into on the FMS computer. 

It asks for the username/password and after I enter the password and hit return, the cursor goes down to a new line and nothing else happens.  The command never finishes, and never errors out.  I let it go overnight once just to see what would happen.

So, I tried to the "Import Custom Certificate" via the FMS Admin interface, I enter the three files, and the password, and FMS crashes and will not start again without rebooting the computer.

The error that comes up is "Safari can't open the page "127.0.0.1:16001/admin-console/app/configuration/sslcertificate" because Safari can't connect to the server "127.0.0.1".

I try stating the admin console again, and get a similar error that the dashboard cannot be opened.

I try the terminal command to start the server and got "Error: 10007 (Requested object does not exist)

I really want to get the proper SSL cert installed.

Any help would be appreciated.

Edited by MacManSteve
Link to comment
Share on other sites

This topic is 399 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.