Jump to content

Stumped by import problem


BFH

This topic is 7869 days old. Please don't post here. Open a new topic instead.

Recommended Posts

FMP 5.5, Mac OS X.1.5 (I've also duplicated the following problem on FMP 5.0 and 6.0 on Mac OS 9.x and on FMP 5.0 on Windows 2000.)

I am trying to import ~380 records, each of which has four text fields, into a FMP database (~600 records) that has the same text fields and quite a few others. One of the fields (ID) is a key field used to relate the database with three others.

I have tried using a FMP file and a tab-delimited text file to import the ~380 records (they originated from an Excel for Windows file). The symptom is the same.

All of the ~380 records import and all of their new records in the database display a value in the ID field. However, the other three fields (last name, first name, and middle initial) all are blank in all of these new (imported) records.

I've shown this problem to a colleague with more FMP experience than me, and he was totally stumped too. He made a clone of my database and then tried to import into the clone. The same symptom occurred.

Given that the problem occurs across the aforementioned three versions of FMP under three different operating systems, I suspect that the problem resides in my files.

Can someone please point me in the proper direction for solving this problem? Many thanks in advance.

Link to comment
Share on other sites

It sounds to me like there is a problem with the file you are importing.

Some things you could try are:

Open the file in a text editor, check to see if it is delimited properly.

If it is not, insert the tabs.

Open the file in Excel, does it appear as expected or is the data for each record in one cell? Do you have the Excel file? If so, import directly from Excel into FM or save as another file type such as .csv and try importing that file.

Link to comment
Share on other sites

Many thanks for replying.

I already had done that; as mentioned, I had tried importing both FMP and tab-delimited text format files and got the same symptom with both.

After reading your message, I tried it again. Same result. I opened the original Excel file, copy/pasted the four fields of interest to an empty spreadsheet, saved to a tab-delimited text file, opened that file in a text editor to make sure that only tabs separated the text, saved again, then imported that file into FMP.

Same exact symptom. The IDs imported flawlessly, the first name, last name, and middle initial fields were completely empty in all imported records.

I do not import the whole Excel file (but instead perform the above steps) because it has extra fields that I do not want to import into the database.

I remain stumped. Any other suggestions? Thanks!

Link to comment
Share on other sites

I just tried saving the four fields of interest as an Excel file from Excel, then imported those records into the database.

Exact same symptom: the IDs imported flawlessly, the other three fields in the imported records were totally blank.

Again, these fields all are populated with values in the preexisting records in the database. Only the imported records have blanks in the three fields (last name, first name, middle name).

Link to comment
Share on other sites

Are you using a script to import, or are you doing the import manually? It sounds like your import order is out of whack. Make sure that you have the correct fields, not only in the right position, but also enabled (solid arrow displayed between left and right side of the list).

Link to comment
Share on other sites

Thank you Bob. You are exactly correct. How embarrassing. In the import window, I had enabled the ID alignment but neglected to do so for the first name, middle name, and last name fields.

To answer your question, I was importing manually.

Again, thanks for taking time to post and point my nose in the proper direction.

Cheers!

Link to comment
Share on other sites

This topic is 7869 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.