Jump to content

Decimal and Date ?


This topic is 7876 days old. Please don't post here. Open a new topic instead.

Recommended Posts

Dear All,

I have checked the REgional setting about the date and decimal ...I set decimal as point (.) and date as 2002-11-27 . And in the filemaker I set it as above too. Since I put on the host...some machines does not accept decimal as point (.) ...they accept virgule (,) ...and the date is screwed up like 27-11-2002 ....Some machine are fine and some are not ... Do you have any idea about it? ...Could you give me a hint how u set it up?

Thanks

Link to comment
Share on other sites

It is so weird that I use decimal point (.) ...but it takes only comma (,) ....when I type "," then get out of the field ...it changes back to point

I really have no idea how to fix this problem since long time we test but no answer.

Somebody has an idea about it?

Thanks

Link to comment
Share on other sites

I check already ...since before putting on the host ...I click use system format ...It only accept point (.) ...when I put that file on the host . I could not control it is using system format or not? but it only accept comma (,) not point (.) ... because I don't want people type decimal as comma (,) ....I did checked regional setting ..use point as decimal ...but since put on the host ...it only accept comma (,)

Can you give me a hint?

Thanks

Link to comment
Share on other sites

The issue here is not directly related to the setting on the host computer or on the client machine where you are viewing the file. It has to do with the settings which were in place at system level on the machine where the file you are viewing was first created. The system settings at the time of file creation are saved as defaults within the file at that point.

To change them, you need to save the file as a clone on a system which has the date and number formats you require, then reimport your data into the clone. Because the clone was created on the new machine, it will take on the formats from that machine as its defaults.

This operates independently of the display formats for fields when they appear on various layouts throughout the solution (which are dependent on how you set them up and can therefore be different in different layouts within the same solution...).

Aside, from this, some limited control of the kind of behaviour you are describing can be achieved by including the 'Use System Defaults [On] script command within a start-up script for each file, but whereas the saveing as a clone procedure permanently alters the file defaults, this approach provides relief for the current application session (on a machine by machine basis) only.

Hope that helps you get to the bottom of the problem.

Link to comment
Share on other sites

Dear All,

I understand a little bit about what you have said ...but I will try on next few days ...I doubt that because of the security level on the host. But sometime when I open the file ...a dialog box pops up as asking if it is the same system format or not? ...but sometimes not asking even not writing the script.

Anyways, thanks All

Anh Tran

Link to comment
Share on other sites

this is exactly my understanding too. but consider this: i have a 'Set System Formats [on]' step in all my startup scripts. i am on a US operating system. went to greece the other day and opened it on my friend's machine. his is also a US operating system. first thing FM flashed was the 'do you want to use the system parms for entry' message. bummer!

Link to comment
Share on other sites

This topic is 7876 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.