Jump to content

problems with "send apple event" and "open url"


Bartjens
 Share

This topic is 6549 days old. Please don't post here. Open a new topic instead.

Recommended Posts

  • Newbies

I've been trying to open word documents on Mac OS 9 and run into several problems. On OSX and Windows I use the "open url" script step and a calculation field that contains the file-path. This works fine but not on Mac OS 9. On OS 9 internet explorer is opened instead of MSWord (file extension is .doc or .dot). In the internet controlpannel both .dot and .doc are listed to open MSWord.

So I've tried to use the "send apple event" script step instead. However, if specify the field containing the file-path I keep getting the message: "<unknown>" could not be found......

I have no idea how to solve this problem.

Also on windows XP i have a problem with "send message". It appears that when there is a space in the file-path (like in Documents and Settings) it refuses to open. If I use send message with the file-path: C:/document.doc it works fine. If I use file-path C:/Documents and Settings/document.doc it doesn't seem to work.

Hope someone can help me with this

Link to comment
Share on other sites

What does your file path for Mac OS 9 look like? When I target a .doc file from Internet Explorer, it opens in MS Word. Here's what a text file URL path looks like:

file:///Macintosh%20HD/Desktop%20Folder/Authorization%20Code

If that doesn't work, I'd use Perform AppleScript and a tell statement. That's really more direct.

tell application "Finder" to open file "Macintosh HD:Users:shortusername:Documents:FileMaker:FM Clients:Power:Plans:databaseplan"

Replace "shortusername" with the user name. You need to full file path here, 'cause OS 9 doesn't know about users. (Notice it doesn't care whether it has an extension. It's probably reading its creator code instead. Same result with Internet Explorer and OpenURL.)

It can be problematic if: 1. MS Word is not running, AND 2. You're booted in OS 9, AND 3. You have MS Word for both OS X and OS 9.

Basically AppleScript will try to open the X version, if it was installed last, and then throw an error message if you're booted in 9. It's a pain, but only a transitional one. Happens with FileMaker also. Works fine once the application is running.

Link to comment
Share on other sites

This topic is 6549 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.