Jump to content

Weird runtime behavior on XP


spb
 Share

This topic is 6506 days old. Please don't post here. Open a new topic instead.

Recommended Posts

I have a runtime bound with FM 5.5 Dev Tool on a Win2000 machine. This works just fine on other W2K machines, plus some earlier Wins I've run across.

However, when installed on XP, it will run great after installation. Then, if you reboot the XP machine, it immediately ceases to respond

(NOT RESPONDING).

After approximately 5 minutes the runtime solution begins responding

again and loads the databases.

Every subsequent execution of the runtime is problem free, until you reboot the machine.

Once the runtime solution is running it runs free of problems.

If you wait the 5 minutes and let the runtime solution completely

open. Windows XP Pro does not generate any activity in the APPLICATION

LOG in the event viewer, but if you crash the solution prematurely it generates this message in the log every time:

-- Application Hang hanging application Common Ground RepWare

v1.5.exe, version 5.5.0.10, hang module hungapp, version 0.0.0.0, hang

address 0x00000000--

This behavior is the same on three XP machines I've tested, but as I said, all other Windows flavors run it just fine.

Any ideas?

Steve Brown

Version: Developer v6

Link to comment
Share on other sites

Steve;

I had a simliar thing with my runtime solutions on XP. In my case I had two runtime solutions which I bound with the same extenstion (not .usr but something else) I removed them both and rebuilt them with two unique extensions (such as .sls and .rcp) this solved the poblem for me .

Give that a try.

Steve

Link to comment
Share on other sites

Steve:

Thanks! I only had one runtime (so it wasn't conflicting with another), but I had accepted FM's "USR" default extension. This has worked for a couple of years on every flavor of Windows but XP.

So I rebound it & made up my own arbitrary extension. Works like a charm.

It's a quick and easy fix, but it bothers me because I don't know why.

Steve B.

Link to comment
Share on other sites

I know LOL it's baffled me too. Looking through XPs registry the problem is that XP gets confused as to who owns what files when you bind multiple solutions with the same extension.

I'm not sure if it's XPs issue or if it's FileMakers issue in how they report file registration to XP. All I know is it didn't used to do that under 2000. LOL

Cheers

Link to comment
Share on other sites

This topic is 6506 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.