Jump to content

Browse Mode, look but do not touch (change things)


 Share

This topic is 6483 days old. Please don't post here. Open a new topic instead.

Recommended Posts

Hi, I've always used a program called Nutshell/Ultrapls which Claris (1989)at one time produced etc. I tryed to up grade to FileMaker Pro and got Ver 3. But found that the Browse Mode would allow anyone to hit a key and change the data at will where as Nutshell/Ultrapls would provied a pop up warning advising you that you had to be in Modify Mode to do so. I could also then lock out that Mode if need be. Well I am trying out FileMaker Pro again and I still can't seem to figure out how or if I can do this. Thought maybe all the brain power on this site may have so help for me.

Thanks,

Ed...

Link to comment
Share on other sites

would provied a pop up warning advising you that you had to be in Modify Mode to do so. I could also then lock out that Mode if need be.

You can also restrict Users through Access Privileges by selecting Edit Records > Limited and specify a calculation based upon other conditions within your file. You haven't updated your profile or indicated your vs/os, but you may also want to investigate a demo by CobaltSky (fp5 format) Automatic Value Locking System.

Hi Ed, just crossed posts with you. smile.gif

If you select one field - any field (while in Layout mode), then Edit > Select All, it will automtically select all fields on the layout (and only fields). Then Field Format them all at once while selected.

Link to comment
Share on other sites

Hi, Ed! I would suggest that you just have 2 layouts, one for data entry and editing and another just for viewing. The viewing layout could be an exact copy of the 1st one, but all you have to do is go to LAYOUT MODE, do a SELECT ALL to select all your fields, go to FORMAT menu and choose FIELD FORMAT. Now, all you have to do is uncheck the box that says "Behavior... Allow entry into field" and you're done.

I just did it in about 10 seconds and it works great.

Jeez... I just read Moonshadow's reply above mine and see almost the same exact answer there, too. I didn't see it at first cuz I only read up to Access Privileges and started typing. Oh, well... hope it helps. Of course, we're just following up on Stephen's reply anyway.

--ST

--ST

Link to comment
Share on other sites

This topic is 6483 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.