Jump to content

"Bad request" and "lost connection"


cinolas
 Share

This topic is 6461 days old. Please don't post here. Open a new topic instead.

Recommended Posts

Greetings,

I am serving a custom web publishing solution using FMP 6.0v4 Unlimited on a Mac running OS 9.2 and I am having 2 problems:

#1 Users from a remote office complained that they weren't able to use this part of our web site, they say they get the following message in a dialog box whenever they try accessing the first FMP generated page:

"Bad Request

The server could not process your request due to a syntax error"

They say they get the same result from all of their computers but one, which is an older computer...

I cannot replicate this problem, I have tried accessing those web pages from different computers in different locations and I cannot seem to get this error to pop out.

At this point I pretty much assume that the problem is with their setup but I have no idea what could cause such a localized problem with such weird effect. Any help would be greatly appreciated.

#2 Lost connection with the host

The same Mac serving the web pages using FMP 6.0v4 Unlimited and OS 9.2 opens the DBs from a WinXPPro box running FMP Server 5.0. A couple of times a week it looses the connection to the host, rendering our web site useless until someone re-opens the DBs. We never have this problem on any other computers connected to the same FMP Server. Any idea why FMP 6.0v4 Unlimited would "loose connection to the host" like that ?

Link to comment
Share on other sites

I wish I could.... we are using an old iMac 350 slot loading which only has 64 megs of RAM and the second ram slot is fried.

I now have reason's to beleive that the "Lost connection" problem is not caused by the iMac but by our WinXPPro box serving the DBs using FMP Server 5. I will try to upgrade to FMP Server 5.5

I'm still looking for suggestions regarding the "Bad request" problem

Link to comment
Share on other sites

Well I'm using 6.0 on Mac OS 9 and apparently the web companion 6.0 update is only available for Mac OS X...don't know why... so I seem to be using the latest web comapnion for my hardware/software setup.

The users that are complaining about the "Bad request" problem are, as far as I know, using pretty standard setups like XPPro or Home and Internet Explorer 6 or so. Very similar to what I have done my testing with but still I cannot replicate. The "old" computer being able to access without a problem is a good clue that would seem to point in the direction of the browser as well but it still does not explain why I cannot replicate the problem from anywhere!

I totally appreciate your help Garry Thanks

Link to comment
Share on other sites

I just got confimation of the computer/network setup of the users having the "Bad request" problem:

Dell Demention 2400

XP Professional

Explorer 6

Qwest DSL

Actiontec from Qwest

And an additional detail: I am serving 2 nearly identical DB from 2 different servers (an iMac and a PC running WinXPPro), the problem is being experienced only on the DB served by the iMac, those same users can access the DB served by the PC no bproblem.

Any help would be greatly appreciated. Thanks

Link to comment
Share on other sites

As Garry mentioned, we had problems w/old web browsers (Netscape, especially) and old Web Companions, but we've been ok since as far as we can tell. If I were to hypothesize, however, I'd guess it has to do w/Microsoft's dropping of Internet Explorer for Mac. I think the last OS9 version of IE for Mac was 5.1.x and the latest for OSX was 5.2.x. If Microsoft stopped development for IE and IE was FMP's only officially supported browser, making Web Companion for Mac compatible for IE6 may have been difficult if there is no IE6 for Mac. Add to that massive overhauls in FMP7 and the dropping of CDML, I am not surprised IE6 support for Mac OS 9 FMP6 Web Companion may not have been a priority.

Now, having said that I must admit that we use FMP-u 5.5 on Mac OS X and our logs show IE6 users accessing our db so there must be something else involved here... maybe classic/OS9 as Garry aludes to? Just theorizing a potential contributing factor...

--ST

Link to comment
Share on other sites

This would all make sens if I had problems connecting from MY explorer 6 (on WinXPPro) but I can access the DB no problem... in fact we cannot seem to find anyone else with that problem other than the complaining user.

Problem #2 Lost Connection

Update on that one... we are still loosing connection to the host once every couple of days. My last moves were to install FMP Server 5.5 and a quality NIC in our FMP Server/WinXPPro box but it didn't solve the problem. And it's not only the iMac (Mac OS 9.1, FMP Unlimited 6.0) loosing the connection but everyone else connected also, meaning it's not a problem with th iMac (or not only) but more likely one with the FMP Server XPPro box or the Linksys BEFSR41 router. What sort of problem would cause that, I don't know...anyone ?

All help and speculation is GREATLY appreciated. Thank you.

Link to comment
Share on other sites

This topic is 6461 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.