Jump to content

Populating Portal Causes Long 'Sorting Records...'


RickGrundy
 Share

This topic is 6439 days old. Please don't post here. Open a new topic instead.

Recommended Posts

I'm having an issue with my DB since importing 3000+ records from our previous DB. When working with about 300 records previously, this didn't happen and I think the larger number of records now has amplified a previous issue.

I am using a portal to show all license keys issued to customers. A couple of the portal fields are calculation fields that show graphical checkboxes instead of the boring FM default checkbox. When I click to the layout that holds this portal, FM pauses for a while and the 'Sorting Records...' dialog appears. It takes about 5 seconds to populate each line in the portal.

The files are linked by the CompanyID, so I don't think its the relationship causing the problem. I remember someone mentioning something about calculations causing speed issues in relationships, can someone refresh my memory? How can I prevent the 'Sorting Records...' dialog from appearing and slowing down the DB?

Thank you in advance and please let me know if additional details are needed.

Link to comment
Share on other sites

If the calculations are unstored (and unindexed) sorting and searching will be much slower. Try taking out the calc. fields and see if that helps. I wouldn't think that an unstored calc would slow things down too much if it isn't included in the sort.

Dana

Link to comment
Share on other sites

Dana,

Thanks for your reply. I think I found my problem. The graphics for the checkboxes are stored as a global field in my Company DB. In the LicenseKey DB, I was displaying the checkboxes through a constant relationship to the Company DB, forcing it to parse every Company before the global checkboxes are displayed. Because its a global field, I simply changed my checkbox calculation to get the checkboxes by the CompanyID relationship so it doesn't go through every company. This seems to have resolved it.

Thanks again for your reply, you gave my brain a kickstart...

Link to comment
Share on other sites

This topic is 6439 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.