Jump to content
Sign in to follow this  
IMIC

Sequelink ODBC Driver error - I need help!

Recommended Posts

I'm at my wits end. I've been trying to get the Sequelink 5.4 ODBC driver to work with FileMaker 7 Server Advanced, but I just can't get it to work.

When I go to Control Panel > Administrative Tools > Data Sources (ODBC)

I try to create a data source using the Sequelink driver, but when I click on 'Test Connect' I get the error:

[DataDirect][ODBC SequeLink driver][sequeLink Client]TCP/IP error

I've tried setting the SequeLink Server Host to localhost and 127.0.0.1

I've tried setting the SequeLink Server Port to 2399, 19996, and 19997. (yeah, I've been told many things)

I already copied the xDBC.fmx and the xDBC Support Folder copied to my FileMaker Server 7ExtensionsPlugins directory.

I've also enabled sharing via ODBC/JDBC in FileMaker Server.

I've been looking at forums all over the place, but none of their solutions have helped me. Any help will be greatly appreciated.

Share this post


Link to post
Share on other sites
Guest

As far as I know the file is open in FM Server.

When I look at it's status using the server administrator program, it says Normal. I can change its status to Closed, so I assume that Normal means that it is open.

Do I need to also install FileMaker Pro on the same machine and open it using that?

-Jason

Share this post


Link to post
Share on other sites

Re: Do I need to also install FileMaker Pro on the same machine and open it using that?

No.

The port which FM uses to talk to FM is 5003. I don't know if you need to try that or not.

Good Luck.

Garry

Share this post


Link to post
Share on other sites

Have you tested the communications? This is done within Data Sources (ODBC).

Share this post


Link to post
Share on other sites

In the Data Sources (ODBC) option, I tried setting the port to 5003, but when I clicked on 'Test Connect' I got the following message.

SequeLink Error: 2315

[DataDirect][OBDC SequeLink driver][sequeLink Client]Network Problem, unknown session conversation protocol.

We ran a program to tell us what ports are currently listening on the server and by what program. We tried all the ports corresponding to FileMaker (including port 5003), but we got similar error messages.

Thanks for your replies Garry and Transpower. We hope you can help more.

Anyone that helps solve this problem will receive a Snickers bar in the mail.

-Jason and Caleb

P.S. Or maybe we'll send you a 'virtual' Snickers bar instead.

Share this post


Link to post
Share on other sites
Guest

I am running the same setup and I copied the file but the plugin DOES NOT APPEAR in the plugins list. If I copy one of the sample plugins in, the sample plugin shows up. I can't turn on the xDBC.fmx plugin, does anybody know why that is?

Share this post


Link to post
Share on other sites

The plugin does not show up for some reason in filemaker server admin tool.

But if you run the command line tool "fmsadmin list plugins" it will show that you have installed the xdbc plugin.

Share this post


Link to post
Share on other sites

(Having previously posted as anonymous)

I can see it in the list, I have enabled it with "fmserver enable plugin 1" (as it's the only plugin there), it shows up as Not Loaded / Enabled. I still cannot connect to the server through ODBC.

Share this post


Link to post
Share on other sites

OK I have everything working on connecting to ODBC now, but I have other issues, please see my new thread.

Share this post


Link to post
Share on other sites

I've installed the xDBC plugin too, but I still can't connect through ODBC. What did you do to make it work?

Share this post


Link to post
Share on other sites

Okay, for those just tuning in, I keep getting a TCP/IP Error when I try to set up my ODBC driver for FMS 7. (see above for more details)

I've tried several new things. At the command line, I typed:

"fmsadmin list plugins"

It showed that the ODBC/JDBC Companion plugin was installed, but that it was disabled. So I typed:

"fmsadmin enable plugin 1"

(1 is the ID for the ODBC/JDBC Companion plugin) but the plugin remained disabled.

I believe this is the root of all the problems I have been having. If anyone can tell me how to get this plugin enabled, I would greatly appreciate it.

-Jason

Share this post


Link to post
Share on other sites

You just enabled it with that command. What I got from FM was that it's not supposed to show up in teh plugin list in the gui. I don't understand that, but then again I don't understand a lot of things FileMaker does.

Share this post


Link to post
Share on other sites

When I typed "fmsadmin enable plugin 1" it immediately told me that the plugin was still disabled, as if the command had done nothing.

Is there another way to enable the plugin, or perhaps it won't enable it because there is an error elsewhere?

-Jason

Share this post


Link to post
Share on other sites

I am not sure if you guys have fixed this in the mean time or what OS you are using, but this might help: if you are using a windows 2000 server, the files from the xDBC plugin you have copied over from the CD will be READ ONLY. If you don't change this you will get connection refused errors because FMSA will not open port 2399. It took me a few days to stumble over this pickle :-( Hope this helps.

Cheers,

T.

Share this post


Link to post
Share on other sites

It worked! Thanks Bounce! I'm naming my firstborn child after you. I knew it was going to be something simple I didn't think of.

Thank you everyone who replied to my initial message. I'm sure I will be posting here again. Now that it's finally working, there are more things for me to break.

-Jason

Share this post


Link to post
Share on other sites

OK so what am I missing here?

Server:

Running FM Server 7 advanced on Win Server 2003 platform.

copied files have been changed from Read Only

xDBC plugin is installed and enabled according to command line.

Action-> Properties ->Clients ->Enable Client Services

Allow ODBC and JDBC connections is checked

Client:

Data Direct Driver is installed

ODBC Connections to localhost/ port 2933 work

ODBC Connections to server's IP/ port 2399 do NOT.

edited to add:

by "not working" I mean: When I test the connection in the ODBC Data Source Admin I get a SequeLink Error: 2306 TCP/IP error, connection refused

FM Develpoer app can connect and open db's on server.

:

thanks

Share this post


Link to post
Share on other sites

OK so installing the updates availble today has fixed the problems

Go figure?

Share this post


Link to post
Share on other sites

What updates did you install? On the client or the server? I just spent 2 & 1/2 hours on the phone with tech support and have yet to resolve this. Any help would be appreciated!

Thanks,

John

Share this post


Link to post
Share on other sites

OK, so lets go back to the original problem in the post. Are you guys trying to say that this original problem can be solved by changing the xdbc files (copied from the cd) into non-read only format will solve this problem?

I have the exact same problem, but got really confused from the different posts in here.

If that is actually the solution, how do you change it from read-only to non-read only?

Thanks!

Share this post


Link to post
Share on other sites

If you are using plain old Server 7 then you're out of luck...

ODBC only works with Server Advanced..... and only in Windows

so just hand over your wallet...

Share this post


Link to post
Share on other sites

I have advanced server 7. But I am testing the DB before deploying it over the network. The file is being developed on a local machine and not on the server.

Do I have to host the file in order for this to work?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.